# CVE-2024-25723: ZenML Server Remote Privilege Escalation Vulnerability

> Remote attackers can escalate privileges by activating user accounts via an insecure API endpoint in ZenML Server.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 27 Feb 2024
- **Updated:** 1 Aug 2024
- **Also known as:** GHSA-vf7j-cmrj-pmmm, PYSEC-2026-2072

## What is CVE-2024-25723?

CVE-2024-25723 is a high-severity authentication bypass vulnerability in n/a, published on 27 Feb 2024. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

ZenML Server in the ZenML machine learning package before 0.46.7 for Python allows remote privilege escalation because the /api/v1/users/{user_name_or_id}/activate REST API endpoint allows access on the basis of a valid username along with a new password in the request body. These are also patched versions: 0.44.4, 0.43.1, and 0.42.2.

Weakness: CWE-284 (Improper Access Control)

## Which versions are affected by CVE-2024-25723?

9 open source packages ship an affected version, including zenml. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `zenml` | PyPI | All versions | 0.42.2, 0.43.1, 0.44.4, 0.46.7 |
| `zenml` | PyPI | All versions | 0.42.2 |
| `zenml` | PyPI | All versions | 0.42.2 |
| `zenml` | PyPI | From 0.43.0 | 0.43.1 |
| `zenml` | PyPI | From 0.43.0 | 0.43.1 |
| `zenml` | PyPI | From 0.44.0 | 0.44.4 |
| `zenml` | PyPI | From 0.44.0 | 0.44.4 |
| `zenml` | PyPI | From 0.45.0 | 0.46.7 |
| `zenml` | PyPI | From 0.45.0 | 0.46.7 |

Products: Zenml Zenml.

## How do I fix CVE-2024-25723?

Upgrade zenml to a fixed version for your release line: 0.42.2, 0.43.1, 0.44.4 or 0.46.7.

## Is CVE-2024-25723 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-25723 exists.

Public exploit code:

- https://github.com/david-botelho-mariano/exploit-CVE-2024-25723 (github_poc): https://github.com/david-botelho-mariano/exploit-CVE-2024-25723
- ZenML ZenML Server - Improper Authentication (nuclei): http/cves/2024/CVE-2024-25723.yaml

## Other vulnerabilities in n/a

- [CVE-2024-2083](https://insights.sbomify.com/CVE-2024-2083/): Directory Traversal in zenml-io/zenml (critical 9.9)
- [CVE-2024-28424](https://insights.sbomify.com/CVE-2024-28424/): Code injection in n/a (high 8.8)
- [CVE-2024-9340](https://insights.sbomify.com/CVE-2024-9340/): Denial of Service (DoS) via Multipart Boundary in zenml-io/zenml (high 7.5)
- [CVE-2024-2035](https://insights.sbomify.com/CVE-2024-2035/): Improper Authorization in zenml-io/zenml (medium 6.5)
- [CVE-2025-8406](https://insights.sbomify.com/CVE-2025-8406/): Path Traversal in zenml-io/zenml (medium 6.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-25723 and fix it if it is affected.

What it is: CVE-2024-25723 is a high-severity authentication bypass vulnerability in n/a, published on 27 Feb 2024. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-25723 exists.

Affected packages and fixed versions:
- zenml (PyPI): affected all versions; fixed in 0.42.2, 0.43.1, 0.44.4, 0.46.7
- zenml (PyPI): affected all versions; fixed in 0.42.2
- zenml (PyPI): affected all versions; fixed in 0.42.2
- zenml (PyPI): affected from 0.43.0; fixed in 0.43.1
- zenml (PyPI): affected from 0.43.0; fixed in 0.43.1
- zenml (PyPI): affected from 0.44.0; fixed in 0.44.4
- zenml (PyPI): affected from 0.44.0; fixed in 0.44.4
- zenml (PyPI): affected from 0.45.0; fixed in 0.46.7
- zenml (PyPI): affected from 0.45.0; fixed in 0.46.7

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-25723/ (Markdown: https://insights.sbomify.com/CVE-2024-25723/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-25723
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-25723
- OSV: https://osv.dev/vulnerability/CVE-2024-25723

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-25723/
Summaries are generated and may contain mistakes; the official description above is the record.
