# CVE-2024-25737: VuFind Server-Side Request Forgery (SSRF) vulnerability

> Remote attackers can exploit SSRF in VuFind to access internal servers and execute XSS via the proxy parameter.

- **Severity:** Medium 6.1 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 22 May 2024
- **Updated:** 13 Feb 2025
- **Also known as:** GHSA-fwhc-mm9q-mqq8

## What is CVE-2024-25737?

CVE-2024-25737 is a medium-severity server-side request forgery vulnerability in n/a, published on 22 May 2024. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

A Server-Side Request Forgery (SSRF) vulnerability in the /Cover/Show route (showAction in CoverController.php) in Open Library Foundation VuFind 2.4 through 9.1 before 9.1.1 allows remote attackers to access internal HTTP servers and perform Cross-Site Scripting (XSS) attacks by proxying arbitrary URLs via the proxy GET parameter.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2024-25737?

2 open source packages ship an affected version, including vufind/vufind.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `vufind/vufind` | Packagist | From 2.4 | 9.1.1 |
| `vufind/vufind` | Packagist | From 2.4 | 9.1.1 |

## How do I fix CVE-2024-25737?

Upgrade vufind/vufind to 9.1.1 or later.

## Is CVE-2024-25737 being exploited?

There is no known exploitation of CVE-2024-25737 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-25737 and fix it if it is affected.

What it is: CVE-2024-25737 is a medium-severity server-side request forgery vulnerability in n/a, published on 22 May 2024. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2024-25737 in the wild and no public exploit code.

Affected packages and fixed versions:
- vufind/vufind (Packagist): affected from 2.4; fixed in 9.1.1
- vufind/vufind (Packagist): affected from 2.4; fixed in 9.1.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-25737/ (Markdown: https://insights.sbomify.com/CVE-2024-25737/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-25737
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-25737
- OSV: https://osv.dev/vulnerability/CVE-2024-25737

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-25737/
Summaries are generated and may contain mistakes; the official description above is the record.
