{"answers":{"affected":"2 open source packages ship an affected version, including vufind/vufind.","exploited":"There is no known exploitation of CVE-2024-25738 in the wild and no public exploit code.","fix":"Upgrade vufind/vufind to 9.1.1 or later.","what":"CVE-2024-25738 is a critical server-side request forgery vulnerability in n/a, published on 22 May 2024. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2024-25738 and fix it if it is affected.\n\nWhat it is: CVE-2024-25738 is a critical server-side request forgery vulnerability in n/a, published on 22 May 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2024-25738 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- vufind/vufind (Packagist): affected from 2.0; fixed in 9.1.1\n- vufind/vufind (Packagist): affected from 2.0; fixed in 9.1.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-25738/ (Markdown: https://insights.sbomify.com/CVE-2024-25738/index.md)","id":"CVE-2024-25738","markdown":"https://insights.sbomify.com/CVE-2024-25738/index.md","name":"CVE-2024-25738","record":{"aliases":["GHSA-wx24-vqrg-m6m5"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution","privilege_escalation"],"network_reachable":"yes","non_default_config":true,"product_category":"VuFind library system","requires_auth":"none","summary":"Remote attackers can exploit SSRF to overwrite configs and achieve RCE if allow_url_include is enabled and the Upgrade route is exposed.","user_interaction":"not_required","vuln_class":"ssrf"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[],"cvss":{"score":9.1,"severity":"critical","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N","version":"3.1"},"cwes":[{"id":"CWE-918","name":"Server-Side Request Forgery"}],"description":"A Server-Side Request Forgery (SSRF) vulnerability in the /Upgrade/FixConfig route in Open Library Foundation VuFind 2.0 through 9.1 before 9.1.1 allows a remote attacker to overwrite local configuration files to gain access to the administrator panel and achieve Remote Code Execution. A mitigating factor is that it requires the allow_url_include PHP runtime setting to be on, which is off in default installations. It also requires the /Upgrade route to be exposed, which is exposed by default after installing VuFind, and is recommended to be disabled by setting autoConfigure to false in config.ini.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"VuFind Server-Side Request Forgery (SSRF) vulnerability","id":"CVE-2024-25738","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"ssrf","year":"2024"},"n_packages":2,"n_references":1,"next":{"headline":"Null dereference in n/a","id":"CVE-2024-25739"},"packages":[{"ecosystem":"Packagist","fixed":["9.1.1"],"introduced":["2.0"],"last_affected":[],"package":"vufind/vufind","purl":null,"source":"GHSA-wx24-vqrg-m6m5"},{"ecosystem":"Packagist","fixed":["9.1.1"],"introduced":["2.0"],"last_affected":[],"package":"vufind/vufind","purl":"pkg:composer/vufind/vufind","source":"GHSA-wx24-vqrg-m6m5"}],"prev":{"headline":"VuFind Server-Side Request Forgery (SSRF) vulnerability","id":"CVE-2024-25737"},"products":["n/a"],"published":"2024-05-22","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2025-02-13","vendors":["n/a"]},"summary":"Remote attackers can exploit SSRF to overwrite configs and achieve RCE if allow_url_include is enabled and the Upgrade route is exposed.","url":"https://insights.sbomify.com/CVE-2024-25738/"}