# CVE-2024-25738: VuFind Server-Side Request Forgery (SSRF) vulnerability

> Remote attackers can exploit SSRF to overwrite configs and achieve RCE if allow_url_include is enabled and the Upgrade route is exposed.

- **Severity:** Critical 9.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 22 May 2024
- **Updated:** 13 Feb 2025
- **Also known as:** GHSA-wx24-vqrg-m6m5

## What is CVE-2024-25738?

CVE-2024-25738 is a critical server-side request forgery vulnerability in n/a, published on 22 May 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

A Server-Side Request Forgery (SSRF) vulnerability in the /Upgrade/FixConfig route in Open Library Foundation VuFind 2.0 through 9.1 before 9.1.1 allows a remote attacker to overwrite local configuration files to gain access to the administrator panel and achieve Remote Code Execution. A mitigating factor is that it requires the allow_url_include PHP runtime setting to be on, which is off in default installations. It also requires the /Upgrade route to be exposed, which is exposed by default after installing VuFind, and is recommended to be disabled by setting autoConfigure to false in config.ini.

Weakness: CWE-918 (Server-Side Request Forgery)

## Which versions are affected by CVE-2024-25738?

2 open source packages ship an affected version, including vufind/vufind.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `vufind/vufind` | Packagist | From 2.0 | 9.1.1 |
| `vufind/vufind` | Packagist | From 2.0 | 9.1.1 |

## How do I fix CVE-2024-25738?

Upgrade vufind/vufind to 9.1.1 or later.

## Is CVE-2024-25738 being exploited?

There is no known exploitation of CVE-2024-25738 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-25738 and fix it if it is affected.

What it is: CVE-2024-25738 is a critical server-side request forgery vulnerability in n/a, published on 22 May 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-25738 in the wild and no public exploit code.

Affected packages and fixed versions:
- vufind/vufind (Packagist): affected from 2.0; fixed in 9.1.1
- vufind/vufind (Packagist): affected from 2.0; fixed in 9.1.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-25738/ (Markdown: https://insights.sbomify.com/CVE-2024-25738/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-25738
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-25738
- OSV: https://osv.dev/vulnerability/CVE-2024-25738

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-25738/
Summaries are generated and may contain mistakes; the official description above is the record.
