{"answers":{"affected":"2 open source packages ship an affected version, including eza. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-25817 exists.","fix":"Upgrade eza to 0.18.2 or later.","what":"CVE-2024-25817 is a high-severity memory corruption vulnerability in n/a, published on 5 Mar 2024. It can only be exploited from the same machine or local network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2024-25817 and fix it if it is affected.\n\nWhat it is: CVE-2024-25817 is a high-severity memory corruption vulnerability in n/a, published on 5 Mar 2024. It can only be exploited from the same machine or local network, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-25817 exists.\n\nAffected packages and fixed versions:\n- eza (crates.io): affected all versions; fixed in 0.18.2\n- eza (crates.io): affected all versions; fixed in 0.18.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-25817/ (Markdown: https://insights.sbomify.com/CVE-2024-25817/index.md)","id":"CVE-2024-25817","markdown":"https://insights.sbomify.com/CVE-2024-25817/index.md","name":"CVE-2024-25817","record":{"aliases":["DEBIAN-CVE-2024-25817","GHSA-3qx3-6hxr-j2ch"],"analysis":{"component_type":"developer_tool","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"eza CLI tool","requires_auth":"none","summary":"Local attackers can execute arbitrary code via buffer overflow in eza when processing specific git directory components.","user_interaction":"not_required","vuln_class":"memory_corruption"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"eza","vendor":"eza.rock"}],"cvss":{"score":8.4,"severity":"high","source":"cisa-adp","vector":"CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-120","name":"Buffer Copy without Checking Size of Input"}],"description":"Buffer Overflow vulnerability in eza before version 0.18.2, allows local attackers to execute arbitrary code via the .git/HEAD, .git/refs, and .git/objects components.","ecosystems":["crates.io"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"eza Potential Heap Overflow Vulnerability for AArch64","id":"CVE-2024-25817","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"crates.io","product":null,"products":[],"type":"memory_corruption","year":"2024"},"n_packages":2,"n_references":2,"next":{"headline":"FydeOS for PC 17.1 R114, FydeOS for VMware 17.0 R114, FydeOS for You 17.1 R114, and OpenFyde R114 were discovered to be configured with the","id":"CVE-2024-25825"},"packages":[{"ecosystem":"crates.io","fixed":["0.18.2"],"introduced":["0"],"last_affected":[],"package":"eza","purl":null,"source":"GHSA-3qx3-6hxr-j2ch"},{"ecosystem":"crates.io","fixed":["0.18.2"],"introduced":["0"],"last_affected":[],"package":"eza","purl":"pkg:cargo/eza","source":"GHSA-3qx3-6hxr-j2ch"}],"prev":{"headline":"Cross-site scripting in n/a","id":"CVE-2024-25814"},"products":["n/a"],"published":"2024-03-05","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"total"},"state":"PUBLISHED","updated":"2024-08-08","vendors":["n/a"]},"summary":"Local attackers can execute arbitrary code via buffer overflow in eza when processing specific git directory components.","url":"https://insights.sbomify.com/CVE-2024-25817/"}