# CVE-2024-25817: eza Potential Heap Overflow Vulnerability for AArch64

> Local attackers can execute arbitrary code via buffer overflow in eza when processing specific git directory components.

- **Severity:** High 8.4 (`CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 5 Mar 2024
- **Updated:** 8 Aug 2024
- **Also known as:** DEBIAN-CVE-2024-25817, GHSA-3qx3-6hxr-j2ch

## What is CVE-2024-25817?

CVE-2024-25817 is a high-severity memory corruption vulnerability in n/a, published on 5 Mar 2024. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

Buffer Overflow vulnerability in eza before version 0.18.2, allows local attackers to execute arbitrary code via the .git/HEAD, .git/refs, and .git/objects components.

Weakness: CWE-120 (Buffer Copy without Checking Size of Input)

## Which versions are affected by CVE-2024-25817?

2 open source packages ship an affected version, including eza. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `eza` | crates.io | All versions | 0.18.2 |
| `eza` | crates.io | All versions | 0.18.2 |

Products: Eza.rock Eza.

## How do I fix CVE-2024-25817?

Upgrade eza to 0.18.2 or later.

## Is CVE-2024-25817 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-25817 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-25817 and fix it if it is affected.

What it is: CVE-2024-25817 is a high-severity memory corruption vulnerability in n/a, published on 5 Mar 2024. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-25817 exists.

Affected packages and fixed versions:
- eza (crates.io): affected all versions; fixed in 0.18.2
- eza (crates.io): affected all versions; fixed in 0.18.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-25817/ (Markdown: https://insights.sbomify.com/CVE-2024-25817/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-25817
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-25817
- OSV: https://osv.dev/vulnerability/CVE-2024-25817

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-25817/
Summaries are generated and may contain mistakes; the official description above is the record.
