# CVE-2024-25929: WordPress Product Catalog Mode For Woocommerce plugin <= 5.0.5 - Broken Access Control vulnerability

> Attackers can bypass authorization checks to access or modify data in the Product Catalog Enquiry for WooCommerce plugin.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 9 Jun 2024
- **Updated:** 28 Apr 2026
- **Also known as:** GHSA-rr2g-6254-88hc

## What is CVE-2024-25929?

CVE-2024-25929 is a medium-severity missing authorization vulnerability in Product Catalog Enquiry for WooCommerce by MultiVendorX, published on 9 Jun 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Missing Authorization vulnerability in MultiVendorX Product Catalog Enquiry for WooCommerce by MultiVendorX.This issue affects Product Catalog Enquiry for WooCommerce by MultiVendorX: from n/a through 5.0.5.

Weakness: CWE-862 (Missing Authorization)

## Which versions are affected by CVE-2024-25929?

It affects 1 product.


Products: Multivendorx Product Catalog Mode for Woocommerce.

## How do I fix CVE-2024-25929?

No fix has been published for CVE-2024-25929 yet. Limit exposure of the affected software until one is available.

## Is CVE-2024-25929 being exploited?

There is no known exploitation of CVE-2024-25929 in the wild and no public exploit code.

## Other vulnerabilities in Product Catalog Enquiry for WooCommerce by MultiVendorX

- [CVE-2023-5348](https://insights.sbomify.com/CVE-2023-5348/): Product Catalog Enquiry for WooCommerce < 5.0.3 - Unauthenticated Stored XSS via Arbitrary Setting Update (medium 6.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-25929 and fix it if it is affected.

What it is: CVE-2024-25929 is a medium-severity missing authorization vulnerability in Product Catalog Enquiry for WooCommerce by MultiVendorX, published on 9 Jun 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-25929 in the wild and no public exploit code.

Affected product: Product Catalog Enquiry for WooCommerce by MultiVendorX. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-25929/ (Markdown: https://insights.sbomify.com/CVE-2024-25929/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-25929
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-25929
- OSV: https://osv.dev/vulnerability/CVE-2024-25929

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-25929/
Summaries are generated and may contain mistakes; the official description above is the record.
