CVE-2024-26016 Apache Superset: Improper authorization validation on dashboards and charts import

Medium 4.3 Published Updated

Low-privilege users can import and modify unauthorized dashboards or charts, gaining ownership of these objects.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2024-26016?

CVE-2024-26016 is a medium-severity missing authorization vulnerability in Apache Superset, published on 28 Feb 2024. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

A low privilege authenticated user could import an existing dashboard or chart that they do not have access to and then modify its metadata, thereby gaining ownership of the object. However, it's important to note that access to the analytical data of these charts and dashboards would still be subject to validation based on data access privileges.

This issue affects Apache Superset: before 3.0.4, from 3.1.0 before 3.1.1.Users are recommended to upgrade to version 3.1.1, which fixes the issue.

Weakness: CWE-863

Which versions are affected by CVE-2024-26016?

6 open source packages ship an affected version, including apache-superset and superset. It affects 1 product.

PackageAffectedFixed in
apache-superset PyPIAll versions3.0.4, 3.1.1
apache-superset PyPIAll versions3.0.4
apache-superset PyPIAll versions3.0.4
apache-superset PyPIFrom 3.1.03.1.1
apache-superset PyPIFrom 3.1.03.1.1
superset BitnamiAll versions4.1.1

Products include Apache Superset.

How do I fix CVE-2024-26016?

Upgrade apache-superset to a fixed version for your release line: 3.0.4 or 3.1.1.

Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.

Is CVE-2024-26016 being exploited?

There is no known exploitation of CVE-2024-26016 in the wild and no public exploit code.

All Apache Superset vulnerabilities

Sources

Also known as BIT-superset-2024-26016, GHSA-3v9r-885j-762g, PYSEC-2026-1158.

Is CVE-2024-26016 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free