{"answers":{"affected":"3 open source packages ship an affected version, including anki. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-26020 exists.","fix":"Upgrade anki to 24.06 or later.","what":"CVE-2024-26020 is a critical code injection vulnerability in Ankitects Anki, published on 22 Jul 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2024-26020 and fix it if it is affected.\n\nWhat it is: CVE-2024-26020 is a critical code injection vulnerability in Ankitects Anki, published on 22 Jul 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-26020 exists.\n\nAffected packages and fixed versions:\n- anki (PyPI): affected all versions; fixed in 24.06\n- anki (PyPI): affected all versions; fixed in 24.06\n- anki (PyPI): affected all versions; fixed in 24.06\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-26020/ (Markdown: https://insights.sbomify.com/CVE-2024-26020/index.md)","id":"CVE-2024-26020","markdown":"https://insights.sbomify.com/CVE-2024-26020/index.md","name":"CVE-2024-26020","record":{"aliases":["DEBIAN-CVE-2024-26020","GHSA-9gq7-p5w9-w899","PYSEC-2026-1116","UBUNTU-CVE-2024-26020"],"analysis":{"component_type":"desktop_application","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Anki flashcard app","requires_auth":"none","summary":"An attacker can execute arbitrary code by sending a specially crafted flashcard to Anki users, potentially compromising their systems.","user_interaction":"required","vuln_class":"code_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"talos","cpe":[{"product":"anki","vendor":"ankiweb"}],"cvss":{"score":9.6,"severity":"critical","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-74","name":"Improper Neutralization of Special Elements in Output Used by a Downstream Component"}],"description":"An arbitrary script execution vulnerability exists in the MPV functionality of Ankitects Anki 24.04. A specially crafted flashcard can lead to a arbitrary code execution. An attacker can send malicious flashcard to trigger this vulnerability.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Ankitects Anki arbitrary script execution vulnerability","id":"CVE-2024-26020","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"code_injection","year":"2024"},"n_packages":3,"n_references":1,"next":{"headline":"Information disclosure in Intel(R) AMT and Intel(R) Standard Manageability","id":"CVE-2024-26021"},"packages":[{"ecosystem":"PyPI","fixed":["24.06"],"introduced":["0"],"last_affected":[],"package":"anki","purl":null,"source":"GHSA-9gq7-p5w9-w899"},{"ecosystem":"PyPI","fixed":["24.06"],"introduced":["0"],"last_affected":[],"package":"anki","purl":"pkg:pypi/anki","source":"GHSA-9gq7-p5w9-w899"},{"ecosystem":"PyPI","fixed":["24.06"],"introduced":["0"],"last_affected":[],"package":"anki","purl":"pkg:pypi/anki","source":"PYSEC-2026-1116"}],"prev":{"headline":"Cross-site scripting in Ninja Forms","id":"CVE-2024-26019"},"products":["Anki"],"published":"2024-07-22","related":[{"cvss_score":5.3,"headline":"Anki Latex Incomplete Blocklist Vulnerability","id":"CVE-2024-29073","kev_date_added":null,"published":"2024-07-22"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"total"},"state":"PUBLISHED","updated":"2025-11-04","vendors":["Ankitects"]},"summary":"An attacker can execute arbitrary code by sending a specially crafted flashcard to Anki users, potentially compromising their systems.","url":"https://insights.sbomify.com/CVE-2024-26020/"}