# CVE-2024-26020: Ankitects Anki arbitrary script execution vulnerability

> An attacker can execute arbitrary code by sending a specially crafted flashcard to Anki users, potentially compromising their systems.

- **Severity:** Critical 9.6 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 22 Jul 2024
- **Updated:** 4 Nov 2025
- **Also known as:** DEBIAN-CVE-2024-26020, GHSA-9gq7-p5w9-w899, PYSEC-2026-1116, UBUNTU-CVE-2024-26020

## What is CVE-2024-26020?

CVE-2024-26020 is a critical code injection vulnerability in Ankitects Anki, published on 22 Jul 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

An arbitrary script execution vulnerability exists in the MPV functionality of Ankitects Anki 24.04. A specially crafted flashcard can lead to a arbitrary code execution. An attacker can send malicious flashcard to trigger this vulnerability.

Weakness: CWE-74 (Improper Neutralization of Special Elements in Output Used by a Downstream Component)

## Which versions are affected by CVE-2024-26020?

3 open source packages ship an affected version, including anki. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `anki` | PyPI | All versions | 24.06 |
| `anki` | PyPI | All versions | 24.06 |
| `anki` | PyPI | All versions | 24.06 |

Products: Ankiweb Anki.

## How do I fix CVE-2024-26020?

Upgrade anki to 24.06 or later.

## Is CVE-2024-26020 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-26020 exists.

## Other vulnerabilities in Ankitects Anki

- [CVE-2024-29073](https://insights.sbomify.com/CVE-2024-29073/): Anki Latex Incomplete Blocklist Vulnerability (medium 5.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-26020 and fix it if it is affected.

What it is: CVE-2024-26020 is a critical code injection vulnerability in Ankitects Anki, published on 22 Jul 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-26020 exists.

Affected packages and fixed versions:
- anki (PyPI): affected all versions; fixed in 24.06
- anki (PyPI): affected all versions; fixed in 24.06
- anki (PyPI): affected all versions; fixed in 24.06

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-26020/ (Markdown: https://insights.sbomify.com/CVE-2024-26020/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-26020
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-26020
- OSV: https://osv.dev/vulnerability/CVE-2024-26020

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-26020/
Summaries are generated and may contain mistakes; the official description above is the record.
