{"answers":{"affected":"2 open source packages ship an affected version, including baserproject/basercms. It affects 1 product.","exploited":"There is no known exploitation of CVE-2024-26128 in the wild and no public exploit code.","fix":"Upgrade baserproject/basercms to 5.0.9 or later.","what":"CVE-2024-26128 is a medium-severity cross-site scripting vulnerability in Basercms Basercms, published on 22 Feb 2024. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2024-26128 and fix it if it is affected.\n\nWhat it is: CVE-2024-26128 is a medium-severity cross-site scripting vulnerability in Basercms Basercms, published on 22 Feb 2024. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2024-26128 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- baserproject/basercms (Packagist): affected all versions; fixed in 5.0.9\n- baserproject/basercms (Packagist): affected all versions; fixed in 5.0.9\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-26128/ (Markdown: https://insights.sbomify.com/CVE-2024-26128/index.md)","id":"CVE-2024-26128","markdown":"https://insights.sbomify.com/CVE-2024-26128/index.md","name":"CVE-2024-26128","record":{"aliases":["GHSA-jjxq-m8h3-4vw5"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution","account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"baserCMS framework","requires_auth":"low_privilege","summary":"Attackers can inject malicious scripts into baserCMS content management, potentially leading to session hijacking or code execution.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"basercms","vendor":"basercms"}],"cvss":{"score":5.4,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"baserCMS is a website development framework. Prior to version 5.0.9, there is a cross-site scripting vulnerability in the content management feature. Version 5.0.9 contains a fix for this vulnerability.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"baserCMS Cross-site Scripting vulnerability in Content Management","id":"CVE-2024-26128","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":"basercms:basercms","products":["basercms:basercms"],"type":"xss","year":"2024"},"n_packages":2,"n_references":3,"next":{"headline":"Prestashop vulnerable to path disclosure in JavaScript variable","id":"CVE-2024-26129"},"packages":[{"ecosystem":"Packagist","fixed":["5.0.9"],"introduced":["0"],"last_affected":[],"package":"baserproject/basercms","purl":null,"source":"GHSA-jjxq-m8h3-4vw5"},{"ecosystem":"Packagist","fixed":["5.0.9"],"introduced":["0"],"last_affected":[],"package":"baserproject/basercms","purl":"pkg:composer/baserproject/basercms","source":"GHSA-jjxq-m8h3-4vw5"}],"prev":{"headline":"Adobe Experience Manager | Improper Input Validation (CWE-20)","id":"CVE-2024-26127"},"products":["basercms"],"published":"2024-02-22","related":[{"cvss_score":9.8,"headline":"baserCMS File Uploader Remote Code Execution (RCE) vulnerability","id":"CVE-2023-25654","kev_date_added":null,"published":"2023-03-23"},{"cvss_score":9.8,"headline":"baserCMS allows any file to be uploaded","id":"CVE-2023-25655","kev_date_added":null,"published":"2023-03-23"},{"cvss_score":9.8,"headline":"baserCMS SQL Injection vulnerability","id":"CVE-2017-10842","kev_date_added":null,"published":"2017-08-28"},{"cvss_score":9.2,"headline":"baserCMS: OS command injection vulnerability in installer","id":"CVE-2026-30880","kev_date_added":null,"published":"2026-03-31"},{"cvss_score":9.1,"headline":"baserCMS: OS Command Injection Leading to Remote Code Execution (RCE)","id":"CVE-2026-21861","kev_date_added":null,"published":"2026-03-31"},{"cvss_score":9.1,"headline":"baserCMS: OS Command Injection in the baserCMS Update Functionality","id":"CVE-2026-30877","kev_date_added":null,"published":"2026-03-31"},{"cvss_score":9.1,"headline":"OS Command Injection Vulnerability and Potential Zip Slip Vulnerability","id":"CVE-2021-41243","kev_date_added":null,"published":"2021-11-26"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2024-08-01","vendors":["baserproject"]},"summary":"Attackers can inject malicious scripts into baserCMS content management, potentially leading to session hijacking or code execution.","url":"https://insights.sbomify.com/CVE-2024-26128/"}