{"answers":{"affected":"2 open source packages ship an affected version, including prestashop/prestashop. It affects 1 product.","exploited":"There is no known exploitation of CVE-2024-26129 in the wild and no public exploit code.","fix":"Upgrade prestashop/prestashop to 8.1.4 or later.","what":"CVE-2024-26129 is a medium-severity vulnerability in Prestashop Prestashop, published on 19 Feb 2024. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2024-26129 and fix it if it is affected.\n\nWhat it is: CVE-2024-26129 is a medium-severity vulnerability in Prestashop Prestashop, published on 19 Feb 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2024-26129 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- prestashop/prestashop (Packagist): affected from 8.1.0; fixed in 8.1.4\n- prestashop/prestashop (Packagist): affected from 8.1.0; fixed in 8.1.4\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-26129/ (Markdown: https://insights.sbomify.com/CVE-2024-26129/index.md)","id":"CVE-2024-26129","markdown":"https://insights.sbomify.com/CVE-2024-26129/index.md","name":"CVE-2024-26129","record":{"aliases":["GHSA-3366-9287-7qpr"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"E-commerce platform","requires_auth":"none","summary":"Attackers can obtain sensitive file path information from a JavaScript variable in PrestaShop, potentially aiding further attacks.","user_interaction":"not_required","vuln_class":"information_disclosure"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"prestashop","vendor":"prestashop"}],"cvss":{"score":5.8,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:L/I:N/A:N","version":"3.1"},"cwes":[{"id":"CWE-22","name":"Improper Limitation of a Pathname to a Restricted Directory"}],"description":"PrestaShop is an open-source e-commerce platform. Starting in version 8.1.0 and prior to version 8.1.4, PrestaShop is vulnerable to path disclosure in a JavaScript variable. A patch is available in version 8.1.4.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Prestashop vulnerable to path disclosure in JavaScript variable","id":"CVE-2024-26129","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":"prestashop:prestashop","products":["prestashop:prestashop"],"type":"information_disclosure","year":"2024"},"n_packages":2,"n_references":3,"next":{"headline":"cryptography NULL pointer dereference with pkcs12.serialize_key_and_certificates when called with a non-matching certificate and private key and an hmac_hash override","id":"CVE-2024-26130"},"packages":[{"ecosystem":"Packagist","fixed":["8.1.4"],"introduced":["8.1.0"],"last_affected":[],"package":"prestashop/prestashop","purl":null,"source":"GHSA-3366-9287-7qpr"},{"ecosystem":"Packagist","fixed":["8.1.4"],"introduced":["8.1.0"],"last_affected":[],"package":"prestashop/prestashop","purl":"pkg:composer/prestashop/prestashop","source":"GHSA-3366-9287-7qpr"}],"prev":{"headline":"baserCMS Cross-site Scripting vulnerability in Content Management","id":"CVE-2024-26128"},"products":["PrestaShop"],"published":"2024-02-19","related":[{"cvss_score":10,"headline":"PrestaShop vulnerable to SQL filter bypass leading to arbitrary write requests using \"SQL Manager\"","id":"CVE-2023-30839","kev_date_added":null,"published":"2023-04-25"},{"cvss_score":10,"headline":"Other in n/a","id":"CVE-2008-5791","kev_date_added":null,"published":"2008-12-31"},{"cvss_score":9.8,"headline":"Server-side request forgery in n/a","id":"CVE-2024-41651","kev_date_added":null,"published":"2024-08-12"},{"cvss_score":9.8,"headline":"Remote code execution in prestashop","id":"CVE-2022-31181","kev_date_added":null,"published":"2022-08-01"},{"cvss_score":9.8,"headline":"SQL injection in n/a","id":"CVE-2021-3110","kev_date_added":null,"published":"2021-01-20"},{"cvss_score":9.8,"headline":"Blind SQL Injection in PrestaShop","id":"CVE-2020-15160","kev_date_added":null,"published":"2020-09-24"},{"cvss_score":9.8,"headline":"Privilege escalation in n/a","id":"CVE-2013-6295","kev_date_added":null,"published":"2020-02-18"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2024-08-01","vendors":["PrestaShop"]},"summary":"Attackers can obtain sensitive file path information from a JavaScript variable in PrestaShop, potentially aiding further attacks.","url":"https://insights.sbomify.com/CVE-2024-26129/"}