# CVE-2024-26129: Prestashop vulnerable to path disclosure in JavaScript variable

> Attackers can obtain sensitive file path information from a JavaScript variable in PrestaShop, potentially aiding further attacks.

- **Severity:** Medium 5.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 19 Feb 2024
- **Updated:** 1 Aug 2024
- **Also known as:** GHSA-3366-9287-7qpr

## What is CVE-2024-26129?

CVE-2024-26129 is a medium-severity vulnerability in Prestashop Prestashop, published on 19 Feb 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

PrestaShop is an open-source e-commerce platform. Starting in version 8.1.0 and prior to version 8.1.4, PrestaShop is vulnerable to path disclosure in a JavaScript variable. A patch is available in version 8.1.4.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2024-26129?

2 open source packages ship an affected version, including prestashop/prestashop. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `prestashop/prestashop` | Packagist | From 8.1.0 | 8.1.4 |
| `prestashop/prestashop` | Packagist | From 8.1.0 | 8.1.4 |

Products: Prestashop Prestashop.

## How do I fix CVE-2024-26129?

Upgrade prestashop/prestashop to 8.1.4 or later.

## Is CVE-2024-26129 being exploited?

There is no known exploitation of CVE-2024-26129 in the wild and no public exploit code.

## Other vulnerabilities in Prestashop Prestashop

- [CVE-2023-30839](https://insights.sbomify.com/CVE-2023-30839/): PrestaShop vulnerable to SQL filter bypass leading to arbitrary write requests using "SQL Manager" (critical 10.0)
- [CVE-2008-5791](https://insights.sbomify.com/CVE-2008-5791/): Other in n/a (critical 10.0)
- [CVE-2024-41651](https://insights.sbomify.com/CVE-2024-41651/): Server-side request forgery in n/a (critical 9.8)
- [CVE-2022-31181](https://insights.sbomify.com/CVE-2022-31181/): Remote code execution in prestashop (critical 9.8)
- [CVE-2021-3110](https://insights.sbomify.com/CVE-2021-3110/): SQL injection in n/a (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-26129 and fix it if it is affected.

What it is: CVE-2024-26129 is a medium-severity vulnerability in Prestashop Prestashop, published on 19 Feb 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-26129 in the wild and no public exploit code.

Affected packages and fixed versions:
- prestashop/prestashop (Packagist): affected from 8.1.0; fixed in 8.1.4
- prestashop/prestashop (Packagist): affected from 8.1.0; fixed in 8.1.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-26129/ (Markdown: https://insights.sbomify.com/CVE-2024-26129/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-26129
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-26129
- OSV: https://osv.dev/vulnerability/CVE-2024-26129

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-26129/
Summaries are generated and may contain mistakes; the official description above is the record.
