# CVE-2024-26134: CBOR2 decoder has potential buffer overflow

> An attacker can crash a service using the cbor2 library by sending a specially crafted long CBOR object, causing a buffer overflow.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 19 Feb 2024
- **Updated:** 13 Feb 2025
- **Also known as:** DEBIAN-CVE-2024-26134, GHSA-375g-39jq-vq7m, PYSEC-2024-155, UBUNTU-CVE-2024-26134, openSUSE-SU-2025:14733-1

## What is CVE-2024-26134?

CVE-2024-26134 is a high-severity denial of service vulnerability in Fedoraproject Fedora, published on 19 Feb 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

cbor2 provides encoding and decoding for the Concise Binary Object Representation (CBOR) (RFC 8949) serialization format. Starting in version 5.5.1 and prior to version 5.6.2, an attacker can crash a service using cbor2 to parse a CBOR binary by sending a long enough object. Version 5.6.2 contains a patch for this issue.

Weakness: CWE-120 (Buffer Copy without Checking Size of Input)

## Which versions are affected by CVE-2024-26134?

3 open source packages ship an affected version, including cbor2. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `cbor2` | PyPI | From 5.5.1 | 5.6.2 |
| `cbor2` | PyPI | From 5.5.1 | 5.6.2 |
| `cbor2` | PyPI | From 5.5.1 | 5.6.2 |
| `python-cbor2` | openSUSE:Tumbleweed | All versions | 5.6.5-2.1 |

Products: Agronholm Cbor2, Fedoraproject Fedora.

## How do I fix CVE-2024-26134?

Upgrade cbor2 to 5.6.2 or later.

## Is CVE-2024-26134 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-26134 exists.

## Other vulnerabilities in Fedoraproject Fedora

- [CVE-2026-26209](https://insights.sbomify.com/CVE-2026-26209/): cbor2 has a Denial of Service via Uncontrolled Recursion in cbor2.loads (high 7.5)
- [CVE-2025-64076](https://insights.sbomify.com/CVE-2025-64076/): cbor2 C extension decoder flaws can cause denial of service (high 7.5)
- [CVE-2025-68131](https://insights.sbomify.com/CVE-2025-68131/): CBORDecoder reuse can leak shareable values across decode calls (medium 5.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-26134 and fix it if it is affected.

What it is: CVE-2024-26134 is a high-severity denial of service vulnerability in Fedoraproject Fedora, published on 19 Feb 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-26134 exists.

Affected packages and fixed versions:
- cbor2 (PyPI): affected from 5.5.1; fixed in 5.6.2
- cbor2 (PyPI): affected from 5.5.1; fixed in 5.6.2
- cbor2 (PyPI): affected from 5.5.1; fixed in 5.6.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-26134/ (Markdown: https://insights.sbomify.com/CVE-2024-26134/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-26134
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-26134
- OSV: https://osv.dev/vulnerability/CVE-2024-26134

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-26134/
Summaries are generated and may contain mistakes; the official description above is the record.
