# CVE-2024-26135: MeshCentral cross-site websocket hijacking (CSWSH) vulnerability

> Attackers can hijack admin sessions via cross-site websocket requests, allowing unauthorized administrative actions on MeshCentral servers.

- **Severity:** High 8.4 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 20 Feb 2024
- **Updated:** 22 Apr 2025
- **Also known as:** GHSA-cp68-qrhr-g9h8

## What is CVE-2024-26135?

CVE-2024-26135 is a high-severity vulnerability in Ylianst MeshCentral, published on 20 Feb 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

MeshCentral is a full computer management web site. Versions prior to 1.1.21 a cross-site websocket hijacking (CSWSH) vulnerability within the control.ashx endpoint. This component is the primary mechanism used within MeshCentral to perform administrative actions on the server. The vulnerability is exploitable when an attacker is able to convince a victim end-user to click on a malicious link to a page hosting an attacker-controlled site. The attacker can then originate a cross-site websocket connection using client-side JavaScript code to connect to `control.ashx` as the victim user within MeshCentral. Version 1.1.21 contains a patch for this issue.

Weakness: CWE-346 (Origin Validation Error)

## Which versions are affected by CVE-2024-26135?

2 open source packages ship an affected version, including meshcentral. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `meshcentral` | npm | All versions | 1.1.21 |
| `meshcentral` | npm | All versions | 1.1.21 |

Products: Meshcentral Meshcentral.

## How do I fix CVE-2024-26135?

Upgrade meshcentral to 1.1.21 or later.

## Is CVE-2024-26135 being exploited?

There is no known exploitation of CVE-2024-26135 in the wild and no public exploit code.

## Other vulnerabilities in Ylianst MeshCentral

- [CVE-2023-51837](https://insights.sbomify.com/CVE-2023-51837/): Ylianst MeshCentral Missing SSL Certificate Validation (critical 9.8)
- [CVE-2023-51838](https://insights.sbomify.com/CVE-2023-51838/): Ylianst MeshCentral 1.1.16 suffers from Use of a Broken or Risky Cryptographic Algorithm. (high 7.5)
- [CVE-2023-51842](https://insights.sbomify.com/CVE-2023-51842/): MeshCentral algorithm-downgrade issue (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-26135 and fix it if it is affected.

What it is: CVE-2024-26135 is a high-severity vulnerability in Ylianst MeshCentral, published on 20 Feb 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2024-26135 in the wild and no public exploit code.

Affected packages and fixed versions:
- meshcentral (npm): affected all versions; fixed in 1.1.21
- meshcentral (npm): affected all versions; fixed in 1.1.21

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-26135/ (Markdown: https://insights.sbomify.com/CVE-2024-26135/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-26135
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-26135
- OSV: https://osv.dev/vulnerability/CVE-2024-26135

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-26135/
Summaries are generated and may contain mistakes; the official description above is the record.
