{"answers":{"affected":"1 open source package ship an affected version, including pycti. It affects 1 product.","exploited":"There is no known exploitation of CVE-2024-26139 in the wild and no public exploit code.","fix":"Upgrade pycti to 5.12.32 or later.","what":"CVE-2024-26139 is a high-severity vulnerability in OpenCTI-Platform opencti, published on 23 May 2024. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2024-26139 and fix it if it is affected.\n\nWhat it is: CVE-2024-26139 is a high-severity vulnerability in OpenCTI-Platform opencti, published on 23 May 2024. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2024-26139 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- pycti (PyPI): affected all versions; fixed in 5.12.32\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-26139/ (Markdown: https://insights.sbomify.com/CVE-2024-26139/index.md)","id":"CVE-2024-26139","markdown":"https://insights.sbomify.com/CVE-2024-26139/index.md","name":"CVE-2024-26139","record":{"aliases":["GHSA-qx4j-f4f2-vjw9","PYSEC-2024-296"],"analysis":{"component_type":"web_application","fix_type":"patch","impacts":["privilege_escalation"],"network_reachable":"yes","non_default_config":false,"product_category":"OpenCTI threat intelligence","requires_auth":"low_privilege","summary":"An authenticated low-privilege user can escalate to administrative privileges in OpenCTI due to missing security controls in profile editing.","user_interaction":"not_required","vuln_class":"privilege_escalation"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"opencti","vendor":"citeum"}],"cvss":{"score":8.3,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:L","version":"3.1"},"cwes":[{"id":"CWE-657","name":"Violation of Secure Design Principles"},{"id":"CWE-284","name":"Improper Access Control"}],"description":"OpenCTI is an open source platform allowing organizations to manage their cyber threat intelligence knowledge and observables. Due to lack of certain security controls on the profile edit functionality, an authenticated attacker with low privileges can gain administrative privileges on the web application.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"OpenCTI Authenticated Privilege Escalation","id":"CVE-2024-26139","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"privilege_escalation","year":"2024"},"n_packages":1,"n_references":1,"next":{"headline":"com.yetanalytics/lrs has Cross-site Scripting Vulnerability in Statement Browser","id":"CVE-2024-26140"},"packages":[{"ecosystem":"PyPI","fixed":["5.12.32"],"introduced":["0"],"last_affected":[],"package":"pycti","purl":"pkg:pypi/pycti","source":"PYSEC-2024-296"}],"prev":{"headline":"License information is public, exposing instance id and license holder details","id":"CVE-2024-26138"},"products":["opencti"],"published":"2024-05-23","related":[{"cvss_score":9.8,"headline":"OpenCTI privilege escalation and unauthenticated access via default admin account","id":"CVE-2026-27960","kev_date_added":null,"published":"2026-05-05"},{"cvss_score":9.1,"headline":"OpenCTI affected by RCE via notifier template","id":"CVE-2026-39980","kev_date_added":null,"published":"2026-04-09"},{"cvss_score":9.1,"headline":"OpenCTI has remote code execution and sensitive secrets exposed through web hook","id":"CVE-2025-24977","kev_date_added":null,"published":"2025-05-05"},{"cvss_score":8.1,"headline":"OpenCTI's lack of Rate Limit lead to OTP brute forcing","id":"CVE-2024-45404","kev_date_added":null,"published":"2024-12-11"},{"cvss_score":7.7,"headline":"OpenCTI has a Semi-Blind SSRF via Unvalidated External URL in Data Ingestion Feature","id":"CVE-2026-21887","kev_date_added":null,"published":"2026-03-12"},{"cvss_score":7.6,"headline":"OpenCTI vulnerable to Denial of Service through web hook","id":"CVE-2025-26621","kev_date_added":null,"published":"2025-05-19"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2024-08-01","vendors":["OpenCTI-Platform"]},"summary":"An authenticated low-privilege user can escalate to administrative privileges in OpenCTI due to missing security controls in profile editing.","url":"https://insights.sbomify.com/CVE-2024-26139/"}