CVE-2024-26140 com.yetanalytics/lrs has Cross-site Scripting Vulnerability in Statement Browser

Medium 4.6 Published Updated

Attackers can inject malicious scripts into the LRS Statement Browser via crafted xAPI statements, potentially executing code in user sessions.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2024-26140?

CVE-2024-26140 is a medium-severity cross-site scripting vulnerability in yetanalytics lrs, published on 20 Feb 2024. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

Official description

com.yetanalytics/lrs is the Yet Analytics Core LRS Library. Prior to version 1.2.17 of the LRS library and version 0.7.5 of SQL LRS, a maliciously crafted xAPI statement could be used to perform script or other tag injection in the LRS Statement Browser. The problem is patched in version 1.2.17 of the LRS library and version 0.7.5 of SQL LRS. No known workarounds exist.

Weakness: CWE-79

Which versions are affected by CVE-2024-26140?

2 open source packages ship an affected version, including com.yetanalytics:lrs. It affects 2 products.

PackageAffectedFixed in
com.yetanalytics:lrs MavenAll versions1.2.17
com.yetanalytics:lrs MavenAll versions1.2.17

Products include Yetanalytics Lrs, Yetanalytics Sql Lrs.

How do I fix CVE-2024-26140?

Upgrade com.yetanalytics:lrs to 1.2.17 or later.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2024-26140 being exploited?

There is no known exploitation of CVE-2024-26140 in the wild and no public exploit code.

Sources

Also known as GHSA-7rw2-3hhp-rc46.

Is CVE-2024-26140 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free