{"answers":{"affected":"2 open source packages ship an affected version, including com.yetanalytics:lrs. It affects 2 products.","exploited":"There is no known exploitation of CVE-2024-26140 in the wild and no public exploit code.","fix":"Upgrade com.yetanalytics:lrs to 1.2.17 or later.","what":"CVE-2024-26140 is a medium-severity cross-site scripting vulnerability in yetanalytics lrs, published on 20 Feb 2024. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2024-26140 and fix it if it is affected.\n\nWhat it is: CVE-2024-26140 is a medium-severity cross-site scripting vulnerability in yetanalytics lrs, published on 20 Feb 2024. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2024-26140 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- com.yetanalytics:lrs (Maven): affected all versions; fixed in 1.2.17\n- com.yetanalytics:lrs (Maven): affected all versions; fixed in 1.2.17\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-26140/ (Markdown: https://insights.sbomify.com/CVE-2024-26140/index.md)","id":"CVE-2024-26140","markdown":"https://insights.sbomify.com/CVE-2024-26140/index.md","name":"CVE-2024-26140","record":{"aliases":["GHSA-7rw2-3hhp-rc46"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Yet Analytics LRS library","requires_auth":"low_privilege","summary":"Attackers can inject malicious scripts into the LRS Statement Browser via crafted xAPI statements, potentially executing code in user sessions.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"lrs","vendor":"yetanalytics"},{"product":"sql_lrs","vendor":"yetanalytics"}],"cvss":{"score":4.6,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:N/I:L/A:L","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"com.yetanalytics/lrs is the Yet Analytics Core LRS Library. Prior to version 1.2.17 of the LRS library and version 0.7.5 of SQL LRS, a maliciously crafted xAPI statement could be used to perform script or other tag injection in the LRS Statement Browser. The problem is patched in version 1.2.17 of the LRS library and version 0.7.5 of SQL LRS. No known workarounds exist.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"com.yetanalytics/lrs has Cross-site Scripting Vulnerability in Statement Browser","id":"CVE-2024-26140","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"xss","year":"2024"},"n_packages":2,"n_references":5,"next":{"headline":"Possible DoS Vulnerability with Range Header in Rack","id":"CVE-2024-26141"},"packages":[{"ecosystem":"Maven","fixed":["1.2.17"],"introduced":["0"],"last_affected":[],"package":"com.yetanalytics:lrs","purl":null,"source":"GHSA-7rw2-3hhp-rc46"},{"ecosystem":"Maven","fixed":["1.2.17"],"introduced":["0"],"last_affected":[],"package":"com.yetanalytics:lrs","purl":"pkg:maven/com.yetanalytics/lrs","source":"GHSA-7rw2-3hhp-rc46"}],"prev":{"headline":"OpenCTI Authenticated Privilege Escalation","id":"CVE-2024-26139"},"products":["lrs"],"published":"2024-02-20","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2024-08-01","vendors":["yetanalytics"]},"summary":"Attackers can inject malicious scripts into the LRS Statement Browser via crafted xAPI statements, potentially executing code in user sessions.","url":"https://insights.sbomify.com/CVE-2024-26140/"}