# CVE-2024-26140: com.yetanalytics/lrs has Cross-site Scripting Vulnerability in Statement Browser

> Attackers can inject malicious scripts into the LRS Statement Browser via crafted xAPI statements, potentially executing code in user sessions.

- **Severity:** Medium 4.6 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:N/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 20 Feb 2024
- **Updated:** 1 Aug 2024
- **Also known as:** GHSA-7rw2-3hhp-rc46

## What is CVE-2024-26140?

CVE-2024-26140 is a medium-severity cross-site scripting vulnerability in yetanalytics lrs, published on 20 Feb 2024. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

com.yetanalytics/lrs is the Yet Analytics Core LRS Library. Prior to version 1.2.17 of the LRS library and version 0.7.5 of SQL LRS, a maliciously crafted xAPI statement could be used to perform script or other tag injection in the LRS Statement Browser. The problem is patched in version 1.2.17 of the LRS library and version 0.7.5 of SQL LRS. No known workarounds exist.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2024-26140?

2 open source packages ship an affected version, including com.yetanalytics:lrs. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `com.yetanalytics:lrs` | Maven | All versions | 1.2.17 |
| `com.yetanalytics:lrs` | Maven | All versions | 1.2.17 |

Products: Yetanalytics Lrs, Yetanalytics Sql Lrs.

## How do I fix CVE-2024-26140?

Upgrade com.yetanalytics:lrs to 1.2.17 or later.

## Is CVE-2024-26140 being exploited?

There is no known exploitation of CVE-2024-26140 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-26140 and fix it if it is affected.

What it is: CVE-2024-26140 is a medium-severity cross-site scripting vulnerability in yetanalytics lrs, published on 20 Feb 2024. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2024-26140 in the wild and no public exploit code.

Affected packages and fixed versions:
- com.yetanalytics:lrs (Maven): affected all versions; fixed in 1.2.17
- com.yetanalytics:lrs (Maven): affected all versions; fixed in 1.2.17

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-26140/ (Markdown: https://insights.sbomify.com/CVE-2024-26140/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-26140
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-26140
- OSV: https://osv.dev/vulnerability/CVE-2024-26140

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-26140/
Summaries are generated and may contain mistakes; the official description above is the record.
