CVE-2024-26146 Possible Denial of Service Vulnerability in Rack Header Parsing

Medium 5.3 Published Updated

Attackers can cause denial of service in Rack applications by sending crafted Accept and Forwarded headers, requiring an upgrade to patched versions.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2024-26146?

CVE-2024-26146 is a medium-severity denial of service vulnerability in Debian Debian Linux, published on 28 Feb 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

Rack is a modular Ruby web server interface. Carefully crafted headers can cause header parsing in Rack to take longer than expected resulting in a possible denial of service issue. Accept and Forwarded headers are impacted. Ruby 3.2 has mitigations for this problem, so Rack applications using Ruby 3.2 or newer are unaffected. This vulnerability is fixed in 2.0.9.4, 2.1.4.4, 2.2.8.1, and 3.0.9.1.

Weakness: CWE-1333

Which versions are affected by CVE-2024-26146?

8 open source packages ship an affected version, including rack. It affects 2 products.

PackageAffectedFixed in
rack RubyGemsAll versions2.0.9.4
rack RubyGemsAll versions2.0.9.4
rack RubyGemsFrom 2.1.02.1.4.4
rack RubyGemsFrom 2.1.02.1.4.4
rack RubyGemsFrom 2.2.02.2.8.1
rack RubyGemsFrom 2.2.02.2.8.1
2 more packages
rack RubyGemsFrom 3.0.03.0.9.1
rack RubyGemsFrom 3.0.03.0.9.1

Products include Debian Debian Linux, Rack Rack.

How do I fix CVE-2024-26146?

Upgrade rack to a fixed version for your release line: 2.0.9.4, 2.1.4.4, 2.2.8.1 or 3.0.9.1.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2024-26146 being exploited?

There is no known exploitation of CVE-2024-26146 in the wild and no public exploit code.

All Debian Debian Linux vulnerabilities

Sources

Also known as DEBIAN-CVE-2024-26146, GHSA-54rr-7fvw-6x8f, OESA-2025-1684, OESA-2025-1685, OESA-2025-1686, UBUNTU-CVE-2024-26146.

Is CVE-2024-26146 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free