# CVE-2024-26146: Possible Denial of Service Vulnerability in Rack Header Parsing

> Attackers can cause denial of service in Rack applications by sending crafted Accept and Forwarded headers, requiring an upgrade to patched versions.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 28 Feb 2024
- **Updated:** 13 Feb 2025
- **Also known as:** DEBIAN-CVE-2024-26146, GHSA-54rr-7fvw-6x8f, OESA-2025-1684, OESA-2025-1685, OESA-2025-1686, UBUNTU-CVE-2024-26146

## What is CVE-2024-26146?

CVE-2024-26146 is a medium-severity denial of service vulnerability in Debian Debian Linux, published on 28 Feb 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Rack is a modular Ruby web server interface. Carefully crafted headers can cause header parsing in Rack to take longer than expected resulting in a possible denial of service issue. Accept and Forwarded headers are impacted. Ruby 3.2 has mitigations for this problem, so Rack applications using Ruby 3.2 or newer are unaffected. This vulnerability is fixed in 2.0.9.4, 2.1.4.4, 2.2.8.1, and 3.0.9.1.

Weakness: CWE-1333 (Inefficient Regular Expression Complexity)

## Which versions are affected by CVE-2024-26146?

8 open source packages ship an affected version, including rack. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `rack` | RubyGems | All versions | 2.0.9.4 |
| `rack` | RubyGems | All versions | 2.0.9.4 |
| `rack` | RubyGems | From 2.1.0 | 2.1.4.4 |
| `rack` | RubyGems | From 2.1.0 | 2.1.4.4 |
| `rack` | RubyGems | From 2.2.0 | 2.2.8.1 |
| `rack` | RubyGems | From 2.2.0 | 2.2.8.1 |
| `rack` | RubyGems | From 3.0.0 | 3.0.9.1 |
| `rack` | RubyGems | From 3.0.0 | 3.0.9.1 |

Products: Debian Debian Linux, Rack Rack.

## How do I fix CVE-2024-26146?

Upgrade rack to a fixed version for your release line: 2.0.9.4, 2.1.4.4, 2.2.8.1 or 3.0.9.1.

## Is CVE-2024-26146 being exploited?

There is no known exploitation of CVE-2024-26146 in the wild and no public exploit code.

## Other vulnerabilities in Debian Debian Linux

- [CVE-2015-3306](https://insights.sbomify.com/CVE-2015-3306/): ProFTPD Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2025-49113](https://insights.sbomify.com/CVE-2025-49113/): RoundCube Webmail Deserialization of Untrusted Data (critical 9.9, exploited in the wild)
- [CVE-2026-24061](https://insights.sbomify.com/CVE-2026-24061/): GNU InetUtils Argument Injection (critical 9.8, exploited in the wild)
- [CVE-2025-39682](https://insights.sbomify.com/CVE-2025-39682/): Linux Kernel Improper Check for Unusual or Exceptional Conditions (critical 9.8, exploited in the wild)
- [CVE-2024-9680](https://insights.sbomify.com/CVE-2024-9680/): Mozilla Firefox Use-After-Free (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-26146 and fix it if it is affected.

What it is: CVE-2024-26146 is a medium-severity denial of service vulnerability in Debian Debian Linux, published on 28 Feb 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-26146 in the wild and no public exploit code.

Affected packages and fixed versions:
- rack (RubyGems): affected all versions; fixed in 2.0.9.4
- rack (RubyGems): affected all versions; fixed in 2.0.9.4
- rack (RubyGems): affected from 2.1.0; fixed in 2.1.4.4
- rack (RubyGems): affected from 2.1.0; fixed in 2.1.4.4
- rack (RubyGems): affected from 2.2.0; fixed in 2.2.8.1
- rack (RubyGems): affected from 2.2.0; fixed in 2.2.8.1
- rack (RubyGems): affected from 3.0.0; fixed in 3.0.9.1
- rack (RubyGems): affected from 3.0.0; fixed in 3.0.9.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-26146/ (Markdown: https://insights.sbomify.com/CVE-2024-26146/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-26146
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-26146
- OSV: https://osv.dev/vulnerability/CVE-2024-26146

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-26146/
Summaries are generated and may contain mistakes; the official description above is the record.
