CVE-2024-26147 Helm's Missing YAML Content Leads To Panic
Attackers can cause Helm to crash by providing malformed YAML files, leading to a denial of service for users and developers.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2024-26147?
CVE-2024-26147 is a high-severity vulnerability in helm, published on 21 Feb 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Helm is a package manager for Charts for Kubernetes. Versions prior to 3.14.2 contain an uninitialized variable vulnerability when Helm parses index and plugin yaml files missing expected content. When either an `index.yaml` file or a plugins `plugin.yaml` file were missing all metadata a panic would occur in Helm. In the Helm SDK, this is found when using the `LoadIndexFile` or `DownloadIndexFile` functions in the `repo` package or the `LoadDir` function in the `plugin` package. For the Helm client this impacts functions around adding a repository and all Helm functions if a malicious plugin is added as Helm inspects all known plugins on each invocation. This issue has been resolved in Helm v3.14.2. If a malicious plugin has been added which is causing all Helm client commands to panic, the malicious plugin can be manually removed from the filesystem. If using Helm SDK versions prior to 3.14.2, calls to affected functions can use `recover` to catch the panic.
Which versions are affected by CVE-2024-26147?
4 open source packages ship an affected version, including helm.sh/helm/v3 and helm. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
helm.sh/helm/v3 Go | All versions | 3.14.2 |
helm.sh/helm/v3 Go | All versions | 3.14.2 |
helm.sh/helm/v3 Go | All versions | 3.14.2 |
helm Bitnami | All versions | 3.14.2 |
Linux distribution packages (3)
cmctl openSUSE:Tumbleweed | All versions | 1.14.4-1.1 |
helm openSUSE:Tumbleweed | All versions | 3.14.2-1.1 |
k9s openSUSE:Tumbleweed | All versions | 0.32.4-2.1 |
Products include Helm Helm.
How do I fix CVE-2024-26147?
Upgrade helm.sh/helm/v3 to 3.14.2 or later.
Is CVE-2024-26147 being exploited?
There is no known exploitation of CVE-2024-26147 in the wild and no public exploit code.
Other vulnerabilities in helm
- CVE-2019-18658 Helm Unsafe Link Following
- CVE-2019-1010275 Helm Improper Certificate Validation
- CVE-2019-25210 Information disclosure in n/a
- CVE-2025-53547 Helm Chart Dependency Updating With Malicious Chart.yaml Content And Symlink Can Lead To Code Execution
- CVE-2020-11013 lookup Function Information Discolosure in Helm
Sources
Also known as AZL-34454, AZL-34584, AZL-38497, BIT-helm-2024-26147, CLEANSTART-2026-DF67169, GHSA-r53h-jv2g-vpx6 and 7 more.