# CVE-2024-26147: Helm's Missing YAML Content Leads To Panic

> Attackers can cause Helm to crash by providing malformed YAML files, leading to a denial of service for users and developers.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 21 Feb 2024
- **Updated:** 14 Aug 2024
- **Also known as:** AZL-34454, AZL-34584, AZL-38497, BIT-helm-2024-26147, CLEANSTART-2026-DF67169, GHSA-r53h-jv2g-vpx6, GO-2024-2575, MINI-5f34-rrqh-37q9, MINI-phhj-p86q-x66g, UBUNTU-CVE-2024-26147, openSUSE-SU-2024:13708-1, openSUSE-SU-2024:13778-1, openSUSE-SU-2024:13918-1

## What is CVE-2024-26147?

CVE-2024-26147 is a high-severity vulnerability in helm, published on 21 Feb 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Helm is a package manager for Charts for Kubernetes. Versions prior to 3.14.2 contain an uninitialized variable vulnerability when Helm parses index and plugin yaml files missing expected content. When either an `index.yaml` file or a plugins `plugin.yaml` file were missing all metadata a panic would occur in Helm. In the Helm SDK, this is found when using the `LoadIndexFile` or `DownloadIndexFile` functions in the `repo` package or the `LoadDir` function in the `plugin` package. For the Helm client this impacts functions around adding a repository and all Helm functions if a malicious plugin is added as Helm inspects all known plugins on each invocation. This issue has been resolved in Helm v3.14.2. If a malicious plugin has been added which is causing all Helm client commands to panic, the malicious plugin can be manually removed from the filesystem. If using Helm SDK versions prior to 3.14.2, calls to affected functions can use `recover` to catch the panic.

Weakness: CWE-908 (Use of Uninitialized Resource), CWE-457 (Use of Uninitialized Variable)

## Which versions are affected by CVE-2024-26147?

4 open source packages ship an affected version, including helm.sh/helm/v3 and helm. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `helm.sh/helm/v3` | Go | All versions | 3.14.2 |
| `helm.sh/helm/v3` | Go | All versions | 3.14.2 |
| `helm.sh/helm/v3` | Go | All versions | 3.14.2 |
| `helm` | Bitnami | All versions | 3.14.2 |
| `cmctl` | openSUSE:Tumbleweed | All versions | 1.14.4-1.1 |
| `helm` | openSUSE:Tumbleweed | All versions | 3.14.2-1.1 |
| `k9s` | openSUSE:Tumbleweed | All versions | 0.32.4-2.1 |

Products: Helm Helm.

## How do I fix CVE-2024-26147?

Upgrade helm.sh/helm/v3 to 3.14.2 or later.

## Is CVE-2024-26147 being exploited?

There is no known exploitation of CVE-2024-26147 in the wild and no public exploit code.

## Other vulnerabilities in helm

- [CVE-2019-18658](https://insights.sbomify.com/CVE-2019-18658/): Helm Unsafe Link Following (critical 9.8)
- [CVE-2019-1010275](https://insights.sbomify.com/CVE-2019-1010275/): Helm Improper Certificate Validation (critical 9.8)
- [CVE-2019-25210](https://insights.sbomify.com/CVE-2019-25210/): Information disclosure in n/a (critical 9.1)
- [CVE-2025-53547](https://insights.sbomify.com/CVE-2025-53547/): Helm Chart Dependency Updating With Malicious Chart.yaml Content And Symlink Can Lead To Code Execution (high 8.5)
- [CVE-2020-11013](https://insights.sbomify.com/CVE-2020-11013/): lookup Function Information Discolosure in Helm (high 8.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-26147 and fix it if it is affected.

What it is: CVE-2024-26147 is a high-severity vulnerability in helm, published on 21 Feb 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-26147 in the wild and no public exploit code.

Affected packages and fixed versions:
- helm.sh/helm/v3 (Go): affected all versions; fixed in 3.14.2
- helm.sh/helm/v3 (Go): affected all versions; fixed in 3.14.2
- helm.sh/helm/v3 (Go): affected all versions; fixed in 3.14.2
- helm (Bitnami): affected all versions; fixed in 3.14.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-26147/ (Markdown: https://insights.sbomify.com/CVE-2024-26147/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-26147
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-26147
- OSV: https://osv.dev/vulnerability/CVE-2024-26147

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-26147/
Summaries are generated and may contain mistakes; the official description above is the record.
