CVE-2024-26149 Vyper _abi_decode Memory Overflow

Low 3.7 Published Updated

Attackers can exploit an integer overflow in Vyper's _abi_decode to read memory outside array bounds, potentially compromising smart contract security.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2024-26149?

CVE-2024-26149 is a low-severity vulnerability in vyperlang vyper, published on 26 Feb 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

Vyper is a pythonic Smart Contract Language for the ethereum virtual machine. If an excessively large value is specified as the starting index for an array in `_abi_decode`, it can cause the read position to overflow. This results in the decoding of values outside the intended array bounds, potentially leading to exploitations in contracts that use arrays within `_abi_decode`. This vulnerability affects 0.3.10 and earlier versions.

Weakness: CWE-119

Which versions are affected by CVE-2024-26149?

3 open source packages ship an affected version, including vyper. It affects 1 product.

PackageAffectedFixed in
vyper PyPIAll versions0.4.0
vyper PyPIAll versions0.4.0
vyper PyPIAll versions0.4.0b1

Products include Vyperlang Vyper.

How do I fix CVE-2024-26149?

Upgrade vyper to a fixed version for your release line: 0.4.0 or 0.4.0b1.

Is CVE-2024-26149 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-26149 exists.

Sources

Also known as GHSA-9p8r-4xp4-gw5w, PYSEC-2024-164.

Is CVE-2024-26149 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free