{"answers":{"affected":"3 open source packages ship an affected version, including vyper. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-26149 exists.","fix":"Upgrade vyper to a fixed version for your release line: 0.4.0 or 0.4.0b1.","what":"CVE-2024-26149 is a low-severity vulnerability in vyperlang vyper, published on 26 Feb 2024. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2024-26149 and fix it if it is affected.\n\nWhat it is: CVE-2024-26149 is a low-severity vulnerability in vyperlang vyper, published on 26 Feb 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-26149 exists.\n\nAffected packages and fixed versions:\n- vyper (PyPI): affected all versions; fixed in 0.4.0\n- vyper (PyPI): affected all versions; fixed in 0.4.0\n- vyper (PyPI): affected all versions; fixed in 0.4.0b1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-26149/ (Markdown: https://insights.sbomify.com/CVE-2024-26149/index.md)","id":"CVE-2024-26149","markdown":"https://insights.sbomify.com/CVE-2024-26149/index.md","name":"CVE-2024-26149","record":{"aliases":["GHSA-9p8r-4xp4-gw5w","PYSEC-2024-164"],"analysis":{"component_type":"developer_tool","fix_type":"upgrade","impacts":["code_execution","data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"Vyper smart contract compiler","requires_auth":"none","summary":"Attackers can exploit an integer overflow in Vyper's _abi_decode to read memory outside array bounds, potentially compromising smart contract security.","user_interaction":"not_required","vuln_class":"integer_overflow"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"vyper","vendor":"vyperlang"}],"cvss":{"score":3.7,"severity":"low","source":"cna","vector":"CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:N/A:N","version":"3.1"},"cwes":[{"id":"CWE-119","name":"Improper Restriction of Operations within the Bounds of a Memory Buffer"}],"description":"Vyper is a pythonic Smart Contract Language for the ethereum virtual machine. If an excessively large value is specified as the starting index for an array in `_abi_decode`, it can cause the read position to overflow. This results in the decoding of values outside the intended array bounds, potentially leading to exploitations in contracts that use arrays within `_abi_decode`. This vulnerability affects 0.3.10 and earlier versions.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Vyper _abi_decode Memory Overflow","id":"CVE-2024-26149","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"integer_overflow","year":"2024"},"n_packages":3,"n_references":1,"next":{"headline":"`@backstage/backend-common` vulnerable to path traversal through symlinks","id":"CVE-2024-26150"},"packages":[{"ecosystem":"PyPI","fixed":["0.4.0"],"introduced":["0"],"last_affected":[],"package":"vyper","purl":null,"source":"GHSA-9p8r-4xp4-gw5w"},{"ecosystem":"PyPI","fixed":["0.4.0"],"introduced":["0"],"last_affected":[],"package":"vyper","purl":"pkg:pypi/vyper","source":"GHSA-9p8r-4xp4-gw5w"},{"ecosystem":"PyPI","fixed":["0.4.0b1"],"introduced":["0"],"last_affected":[],"package":"vyper","purl":"pkg:pypi/vyper","source":"PYSEC-2024-164"}],"prev":{"headline":"Querybook's Stored Cross-Site Scripting vulnerability allows Privilege Elevation","id":"CVE-2024-26148"},"products":["vyper"],"published":"2024-02-26","related":[{"cvss_score":9.8,"headline":"Vyper array negative index vulnerability","id":"CVE-2024-24563","kev_date_added":null,"published":"2024-02-07"},{"cvss_score":9.8,"headline":"Vyper bounds check on built-in `slice()` function can be overflowed","id":"CVE-2024-24561","kev_date_added":null,"published":"2024-02-01"},{"cvss_score":9.1,"headline":"Vyper incorrectly allocated named re-entrancy locks","id":"CVE-2023-39363","kev_date_added":null,"published":"2023-08-07"},{"cvss_score":8.8,"headline":"Integer bounds error in Vyper","id":"CVE-2022-24845","kev_date_added":null,"published":"2022-04-13"},{"cvss_score":8.2,"headline":"Multiple evaluation of contract address in call in vyper","id":"CVE-2022-29255","kev_date_added":null,"published":"2022-06-06"},{"cvss_score":8.1,"headline":"Vyper vulnerable to memory corruption in certain builtins utilizing `msize`","id":"CVE-2023-42443","kev_date_added":null,"published":"2023-09-18"},{"cvss_score":7.5,"headline":"Vyper has incorrect storage layout for contracts containing large arrays","id":"CVE-2023-46247","kev_date_added":null,"published":"2023-12-13"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2024-08-22","vendors":["vyperlang"]},"summary":"Attackers can exploit an integer overflow in Vyper's _abi_decode to read memory outside array bounds, potentially compromising smart contract security.","url":"https://insights.sbomify.com/CVE-2024-26149/"}