# CVE-2024-26149: Vyper _abi_decode Memory Overflow

> Attackers can exploit an integer overflow in Vyper's _abi_decode to read memory outside array bounds, potentially compromising smart contract security.

- **Severity:** Low 3.7 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 26 Feb 2024
- **Updated:** 22 Aug 2024
- **Also known as:** GHSA-9p8r-4xp4-gw5w, PYSEC-2024-164

## What is CVE-2024-26149?

CVE-2024-26149 is a low-severity vulnerability in vyperlang vyper, published on 26 Feb 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Vyper is a pythonic Smart Contract Language for the ethereum virtual machine. If an excessively large value is specified as the starting index for an array in `_abi_decode`, it can cause the read position to overflow. This results in the decoding of values outside the intended array bounds, potentially leading to exploitations in contracts that use arrays within `_abi_decode`. This vulnerability affects 0.3.10 and earlier versions.

Weakness: CWE-119 (Improper Restriction of Operations within the Bounds of a Memory Buffer)

## Which versions are affected by CVE-2024-26149?

3 open source packages ship an affected version, including vyper. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `vyper` | PyPI | All versions | 0.4.0 |
| `vyper` | PyPI | All versions | 0.4.0 |
| `vyper` | PyPI | All versions | 0.4.0b1 |

Products: Vyperlang Vyper.

## How do I fix CVE-2024-26149?

Upgrade vyper to a fixed version for your release line: 0.4.0 or 0.4.0b1.

## Is CVE-2024-26149 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-26149 exists.

## Other vulnerabilities in vyperlang vyper

- [CVE-2024-24563](https://insights.sbomify.com/CVE-2024-24563/): Vyper array negative index vulnerability (critical 9.8)
- [CVE-2024-24561](https://insights.sbomify.com/CVE-2024-24561/): Vyper bounds check on built-in `slice()` function can be overflowed (critical 9.8)
- [CVE-2023-39363](https://insights.sbomify.com/CVE-2023-39363/): Vyper incorrectly allocated named re-entrancy locks (critical 9.1)
- [CVE-2022-24845](https://insights.sbomify.com/CVE-2022-24845/): Integer bounds error in Vyper (high 8.8)
- [CVE-2022-29255](https://insights.sbomify.com/CVE-2022-29255/): Multiple evaluation of contract address in call in vyper (high 8.2)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-26149 and fix it if it is affected.

What it is: CVE-2024-26149 is a low-severity vulnerability in vyperlang vyper, published on 26 Feb 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-26149 exists.

Affected packages and fixed versions:
- vyper (PyPI): affected all versions; fixed in 0.4.0
- vyper (PyPI): affected all versions; fixed in 0.4.0
- vyper (PyPI): affected all versions; fixed in 0.4.0b1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-26149/ (Markdown: https://insights.sbomify.com/CVE-2024-26149/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-26149
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-26149
- OSV: https://osv.dev/vulnerability/CVE-2024-26149

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-26149/
Summaries are generated and may contain mistakes; the official description above is the record.
