# CVE-2024-26150: `@backstage/backend-common` vulnerable to path traversal through symlinks

> Attackers can exploit symlink injection to bypass path checks in Backstage backend libraries, potentially reading or modifying unauthorized files.

- **Severity:** High 8.7 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:C/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 23 Feb 2024
- **Updated:** 1 Aug 2024
- **Also known as:** GHSA-2fc9-xpp8-2g9h

## What is CVE-2024-26150?

CVE-2024-26150 is a high-severity path traversal vulnerability in backstage, published on 23 Feb 2024. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

`@backstage/backend-common` is a common functionality library for backends for Backstage, an open platform for building developer portals. In `@backstage/backend-common` prior to versions 0.21.1, 0.20.2, and 0.19.10, paths checks with the `resolveSafeChildPath` utility were not exhaustive enough, leading to risk of path traversal vulnerabilities if symlinks can be injected by attackers. This issue is patched in `@backstage/backend-common` versions 0.21.1, 0.20.2, and 0.19.10.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2024-26150?

6 open source packages ship an affected version, including @backstage/backend-common. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@backstage/backend-common` | npm | All versions | 0.19.10 |
| `@backstage/backend-common` | npm | All versions | 0.19.10 |
| `@backstage/backend-common` | npm | From 0.20.0 | 0.20.2 |
| `@backstage/backend-common` | npm | From 0.20.0 | 0.20.2 |
| `@backstage/backend-common` | npm | From 0.21.0 | 0.21.1 |
| `@backstage/backend-common` | npm | From 0.21.0 | 0.21.1 |

Products: Linuxfoundation Backstage Backend-Common.

## How do I fix CVE-2024-26150?

Upgrade @backstage/backend-common to a fixed version for your release line: 0.19.10, 0.20.2 or 0.21.1.

## Is CVE-2024-26150 being exploited?

There is no known exploitation of CVE-2024-26150 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-26150 and fix it if it is affected.

What it is: CVE-2024-26150 is a high-severity path traversal vulnerability in backstage, published on 23 Feb 2024. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-26150 in the wild and no public exploit code.

Affected packages and fixed versions:
- @backstage/backend-common (npm): affected all versions; fixed in 0.19.10
- @backstage/backend-common (npm): affected all versions; fixed in 0.19.10
- @backstage/backend-common (npm): affected from 0.20.0; fixed in 0.20.2
- @backstage/backend-common (npm): affected from 0.20.0; fixed in 0.20.2
- @backstage/backend-common (npm): affected from 0.21.0; fixed in 0.21.1
- @backstage/backend-common (npm): affected from 0.21.0; fixed in 0.21.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-26150/ (Markdown: https://insights.sbomify.com/CVE-2024-26150/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-26150
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-26150
- OSV: https://osv.dev/vulnerability/CVE-2024-26150

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-26150/
Summaries are generated and may contain mistakes; the official description above is the record.
