# CVE-2024-26164: Microsoft Django Backend for SQL Server Remote Code Execution Vulnerability

> Attackers can execute arbitrary code via the Microsoft Django Backend for SQL Server, requiring immediate patching by developers using this library.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H/E:U/RL:O/RC:C`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 12 Mar 2024
- **Updated:** 3 May 2025
- **Also known as:** GHSA-vmqv-47j8-gwv8, PYSEC-2026-1684

## What is CVE-2024-26164?

CVE-2024-26164 is a high-severity code injection vulnerability in Microsoft SQL Server backend for Django, published on 12 Mar 2024. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Microsoft Django Backend for SQL Server Remote Code Execution Vulnerability

Weakness: CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2024-26164?

3 open source packages ship an affected version, including mssql-django. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `mssql-django` | PyPI | All versions | 1.4.1 |
| `mssql-django` | PyPI | All versions | 1.4.1 |
| `mssql-django` | PyPI | All versions | 1.4.1 |

Products: Microsoft Django Backend.

## How do I fix CVE-2024-26164?

Upgrade mssql-django to 1.4.1 or later.

## Is CVE-2024-26164 being exploited?

There is no known exploitation of CVE-2024-26164 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-26164 and fix it if it is affected.

What it is: CVE-2024-26164 is a high-severity code injection vulnerability in Microsoft SQL Server backend for Django, published on 12 Mar 2024. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-26164 in the wild and no public exploit code.

Affected packages and fixed versions:
- mssql-django (PyPI): affected all versions; fixed in 1.4.1
- mssql-django (PyPI): affected all versions; fixed in 1.4.1
- mssql-django (PyPI): affected all versions; fixed in 1.4.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-26164/ (Markdown: https://insights.sbomify.com/CVE-2024-26164/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-26164
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-26164
- OSV: https://osv.dev/vulnerability/CVE-2024-26164

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-26164/
Summaries are generated and may contain mistakes; the official description above is the record.
