CVE-2024-26269 Liferay Portal Frontend JS module's portlet.js and Liferay DXP vulnerable to Cross-site Scripting
Remote attackers can inject arbitrary web script or HTML via the URL anchor in Liferay Portal, potentially compromising user sessions.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2024-26269?
CVE-2024-26269 is a critical cross-site scripting vulnerability in Liferay Digital Experience Platform, published on 21 Feb 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Official description
Cross-site scripting (XSS) vulnerability in the Frontend JS module's portlet.js in Liferay Portal 7.2.0 through 7.4.3.37, and Liferay DXP 7.4 before update 38, 7.3 before update 11, 7.2 before fix pack 20, and older unsupported versions allows remote attackers to inject arbitrary web script or HTML via the anchor (hash) part of a URL.
Weakness: CWE-79
Which versions are affected by CVE-2024-26269?
8 open source packages ship an affected version, including com.liferay.portal:release.dxp.bom and com.liferay.portal:release.portal.bom. It affects 2 products.
| Package | Affected | Fixed in |
|---|---|---|
com.liferay.portal:release.dxp.bom Maven | From 7.2.0 | 7.2.10.fp20 |
com.liferay.portal:release.dxp.bom Maven | From 7.2.0 | 7.2.10.fp20 |
com.liferay.portal:release.dxp.bom Maven | From 7.3.10.ep3 | 7.3.10.u11 |
com.liferay.portal:release.dxp.bom Maven | From 7.3.10.ep3 | 7.3.10.u11 |
com.liferay.portal:release.dxp.bom Maven | From 7.4.13.u1 | 7.4.13.u38 |
com.liferay.portal:release.dxp.bom Maven | From 7.4.13.u1 | 7.4.13.u38 |
2 more packages
com.liferay.portal:release.portal.bom Maven | From 7.2.0 | 7.4.3.38 |
com.liferay.portal:release.portal.bom Maven | From 7.2.0 | 7.4.3.38 |
Products include Liferay Digital Experience Platform, Liferay Liferay Portal.
How do I fix CVE-2024-26269?
Upgrade com.liferay.portal:release.dxp.bom to a fixed version for your release line: 7.2.10.fp20, 7.3.10.u11 or 7.4.13.u38.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2024-26269 being exploited?
There is no known exploitation of CVE-2024-26269 in the wild and no public exploit code.
Other vulnerabilities in Liferay Digital Experience Platform
- CVE-2024-8980 Liferay Portal and Liferay DXP Vulnerable to CSRF in the Script Console
- CVE-2023-42496 Liferay Portal and Liferay DXP vulnerable to reflected Cross-site Scripting
- CVE-2023-42498 Liferay Portal Language Override edit screen and Liferay DXP vulnerable to reflected Cross-site Scripting
- CVE-2024-25147 Liferay Portal and Liferay DXP vulnerable to Cross-site Scripting
- CVE-2024-25145 Liferay Portal stored cross-site scripting (XSS) vulnerability
Sources
Also known as GHSA-rwhv-hvj2-qrqm.