CVE-2024-26308 Apache Commons Compress: OutOfMemoryError unpacking broken Pack200 file
Attackers can cause denial of service via OutOfMemoryError by providing a broken Pack200 file to applications using this library.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Local or same network only
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2024-26308?
CVE-2024-26308 is a medium-severity denial of service vulnerability in Apache Commons Compress, published on 19 Feb 2024. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Official description
Allocation of Resources Without Limits or Throttling vulnerability in Apache Commons Compress.This issue affects Apache Commons Compress: from 1.21 before 1.26.
Users are recommended to upgrade to version 1.26, which fixes the issue.
Weakness: CWE-770
Which versions are affected by CVE-2024-26308?
2 open source packages ship an affected version, including org.apache.commons:commons-compress. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
org.apache.commons:commons-compress Maven | From 1.21 | 1.26.0 |
org.apache.commons:commons-compress Maven | From 1.21 | 1.26.0 |
Products include Apache Commons Compress.
How do I fix CVE-2024-26308?
Upgrade org.apache.commons:commons-compress to 1.26.0 or later.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2024-26308 being exploited?
There is no known exploitation of CVE-2024-26308 in the wild and no public exploit code.
Public exploit code: 1 proofs of concept on GitHub.
Other vulnerabilities in Apache Commons Compress
- CVE-2024-25710 Apache Commons Compress: Denial of service caused by an infinite loop for a corrupted DUMP file
- CVE-2021-35515 Apache Commons Compress 1.6 to 1.20 denial of service vulnerability
- CVE-2021-35516 Apache Commons Compress 1.6 to 1.20 denial of service vulnerability
- CVE-2021-35517 Apache Commons Compress 1.1 to 1.20 denial of service vulnerability
- CVE-2021-36090 Apache Commons Compress 1.0 to 1.20 denial of service vulnerability
Sources
Also known as CLEANSTART-2026-DR01858, CLEANSTART-2026-TZ12135, DEBIAN-CVE-2024-26308, ECHO-db89-1b8d-3c4a, GHSA-4265-ccf5-phj5, MINI-4237-j7vw-7vq4 and 8 more.