{"answers":{"affected":"2 open source packages ship an affected version, including org.apache.commons:commons-compress. It affects 1 product.","exploited":"There is no known exploitation of CVE-2024-26308 in the wild and no public exploit code.","fix":"Upgrade org.apache.commons:commons-compress to 1.26.0 or later.","what":"CVE-2024-26308 is a medium-severity denial of service vulnerability in Apache Commons Compress, published on 19 Feb 2024. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2024-26308 and fix it if it is affected.\n\nWhat it is: CVE-2024-26308 is a medium-severity denial of service vulnerability in Apache Commons Compress, published on 19 Feb 2024. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2024-26308 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.apache.commons:commons-compress (Maven): affected from 1.21; fixed in 1.26.0\n- org.apache.commons:commons-compress (Maven): affected from 1.21; fixed in 1.26.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-26308/ (Markdown: https://insights.sbomify.com/CVE-2024-26308/index.md)","id":"CVE-2024-26308","markdown":"https://insights.sbomify.com/CVE-2024-26308/index.md","name":"CVE-2024-26308","record":{"aliases":["CLEANSTART-2026-DR01858","CLEANSTART-2026-TZ12135","DEBIAN-CVE-2024-26308","ECHO-db89-1b8d-3c4a","GHSA-4265-ccf5-phj5","MINI-4237-j7vw-7vq4","MINI-8wq2-5hcc-cm56","MINI-gr37-4jp2-245j","MINI-p8p8-74x2-8cjm","MINI-qcmr-6j5v-748h","MINI-r8x4-c4w6-jjwq","MINI-vw3v-x3xr-rgf5","ROOT-APP-MAVEN-CVE-2024-26308","UBUNTU-CVE-2024-26308"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"Java compression library","requires_auth":"none","summary":"Attackers can cause denial of service via OutOfMemoryError by providing a broken Pack200 file to applications using this library.","user_interaction":"required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"apache","cpe":[{"product":"commons_compress","vendor":"apache"}],"cvss":{"score":5.5,"severity":"medium","source":"cisa-adp","vector":"CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H","version":"3.1"},"cwes":[{"id":"CWE-770","name":"Allocation of Resources Without Limits or Throttling"}],"description":"Allocation of Resources Without Limits or Throttling vulnerability in Apache Commons Compress.This issue affects Apache Commons Compress: from 1.21 before 1.26.\n\nUsers are recommended to upgrade to version 1.26, which fixes the issue.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":"2024-08-11","github_poc":1,"max_poc_stars":0,"metasploit":0,"nuclei":0,"refs":[{"date":"2024-08-11T14:10:14Z","kind":"github_poc","ref":"https://github.com/crazycatMyopic/cve","stars":0,"title":"Docker Deskop giving issue CVE-2024-26308 for maven [reproduce]"}],"tier":"poc_unverified"},"has_fix":true,"headline":"Apache Commons Compress: OutOfMemoryError unpacking broken Pack200 file","id":"CVE-2024-26308","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"denial_of_service","year":"2024"},"n_packages":2,"n_references":3,"next":{"headline":"Information disclosure in n/a","id":"CVE-2024-26309"},"packages":[{"ecosystem":"Maven","fixed":["1.26.0"],"introduced":["1.21"],"last_affected":[],"package":"org.apache.commons:commons-compress","purl":null,"source":"GHSA-4265-ccf5-phj5"},{"ecosystem":"Maven","fixed":["1.26.0"],"introduced":["1.21"],"last_affected":[],"package":"org.apache.commons:commons-compress","purl":"pkg:maven/org.apache.commons/commons-compress","source":"GHSA-4265-ccf5-phj5"}],"prev":{"headline":"Apache Doris: Possible race condition","id":"CVE-2024-26307"},"products":["Apache Commons Compress"],"published":"2024-02-19","related":[{"cvss_score":8.1,"headline":"Apache Commons Compress: Denial of service caused by an infinite loop for a corrupted DUMP file","id":"CVE-2024-25710","kev_date_added":null,"published":"2024-02-19"},{"cvss_score":7.5,"headline":"Apache Commons Compress 1.6 to 1.20 denial of service vulnerability","id":"CVE-2021-35515","kev_date_added":null,"published":"2021-07-13"},{"cvss_score":7.5,"headline":"Apache Commons Compress 1.6 to 1.20 denial of service vulnerability","id":"CVE-2021-35516","kev_date_added":null,"published":"2021-07-13"},{"cvss_score":7.5,"headline":"Apache Commons Compress 1.1 to 1.20 denial of service vulnerability","id":"CVE-2021-35517","kev_date_added":null,"published":"2021-07-13"},{"cvss_score":7.5,"headline":"Apache Commons Compress 1.0 to 1.20 denial of service vulnerability","id":"CVE-2021-36090","kev_date_added":null,"published":"2021-07-13"},{"cvss_score":7.5,"headline":"Denial of Service in Apache Commons Compress","id":"CVE-2019-12402","kev_date_added":null,"published":"2019-08-29"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"},{"class":"open","licence":"CC0","name":"PoC-in-GitHub"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-03-27","vendors":["Apache Software Foundation"]},"summary":"Attackers can cause denial of service via OutOfMemoryError by providing a broken Pack200 file to applications using this library.","url":"https://insights.sbomify.com/CVE-2024-26308/"}