{"answers":{"affected":"1 open source package ship an affected version, including fluent-bit. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-26455 exists.","fix":"Upgrade fluent-bit to 2.2.3 or later.","what":"CVE-2024-26455 is a high-severity use after free vulnerability in n/a, published on 26 Feb 2024. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2024-26455 and fix it if it is affected.\n\nWhat it is: CVE-2024-26455 is a high-severity use after free vulnerability in n/a, published on 26 Feb 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-26455 exists.\n\nAffected packages and fixed versions:\n- fluent-bit (Bitnami): affected from 2.2.2; fixed in 2.2.3\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-26455/ (Markdown: https://insights.sbomify.com/CVE-2024-26455/index.md)","id":"CVE-2024-26455","markdown":"https://insights.sbomify.com/CVE-2024-26455/index.md","name":"CVE-2024-26455","record":{"aliases":["AZL-35449","AZL-35472","BIT-fluent-bit-2024-26455","GHSA-7xfv-2p7x-fhmv"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["code_execution","denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Fluent Bit logging agent","requires_auth":"none","summary":"A use-after-free flaw in Fluent Bit allows attackers to potentially execute arbitrary code or cause a denial of service.","user_interaction":"not_required","vuln_class":"use_after_free"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"fluent_bit","vendor":"treasuredata"}],"cvss":{"score":7.5,"severity":"high","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","version":"3.1"},"cwes":[{"id":"CWE-416","name":"Use After Free"}],"description":"fluent-bit 2.2.2 contains a Use-After-Free vulnerability in /fluent-bit/plugins/custom_calyptia/calyptia.c.","ecosystems":["Bitnami"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Use after free in n/a","id":"CVE-2024-26455","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":null,"products":[],"type":"use_after_free","year":"2024"},"n_packages":1,"n_references":1,"next":{"headline":"Denial of service in n/a","id":"CVE-2024-26458"},"packages":[{"ecosystem":"Bitnami","fixed":["2.2.3"],"introduced":["2.2.2"],"last_affected":[],"package":"fluent-bit","purl":"pkg:bitnami/fluent-bit","source":"BIT-fluent-bit-2024-26455"}],"prev":{"headline":"Cross-site scripting in n/a","id":"CVE-2024-26454"},"products":["n/a"],"published":"2024-02-26","related":[{"cvss_score":9.8,"headline":"Fluent Bit Memory Corruption Vulnerability","id":"CVE-2024-4323","kev_date_added":null,"published":"2024-05-20"},{"cvss_score":9.8,"headline":"Use after free in n/a","id":"CVE-2021-36088","kev_date_added":null,"published":"2021-07-01"},{"cvss_score":9.1,"headline":"CVE-2025-12977","id":"CVE-2025-12977","kev_date_added":null,"published":"2025-11-24"},{"cvss_score":8.8,"headline":"CVE-2025-12970","id":"CVE-2025-12970","kev_date_added":null,"published":"2025-11-24"},{"cvss_score":7.8,"headline":"Use after free in n/a","id":"CVE-2021-46878","kev_date_added":null,"published":"2023-04-11"},{"cvss_score":7.8,"headline":"Memory corruption in n/a","id":"CVE-2021-46879","kev_date_added":null,"published":"2023-04-11"},{"cvss_score":7.8,"headline":"Memory corruption in n/a","id":"CVE-2020-35963","kev_date_added":null,"published":"2021-01-03"}],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2024-08-28","vendors":["n/a"]},"summary":"A use-after-free flaw in Fluent Bit allows attackers to potentially execute arbitrary code or cause a denial of service.","url":"https://insights.sbomify.com/CVE-2024-26455/"}