# CVE-2024-26455: Use after free in n/a

> A use-after-free flaw in Fluent Bit allows attackers to potentially execute arbitrary code or cause a denial of service.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 26 Feb 2024
- **Updated:** 28 Aug 2024
- **Also known as:** AZL-35449, AZL-35472, BIT-fluent-bit-2024-26455, GHSA-7xfv-2p7x-fhmv

## What is CVE-2024-26455?

CVE-2024-26455 is a high-severity use after free vulnerability in n/a, published on 26 Feb 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

fluent-bit 2.2.2 contains a Use-After-Free vulnerability in /fluent-bit/plugins/custom_calyptia/calyptia.c.

Weakness: CWE-416 (Use After Free)

## Which versions are affected by CVE-2024-26455?

1 open source package ship an affected version, including fluent-bit. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `fluent-bit` | Bitnami | From 2.2.2 | 2.2.3 |

Products: Treasuredata Fluent Bit.

## How do I fix CVE-2024-26455?

Upgrade fluent-bit to 2.2.3 or later.

## Is CVE-2024-26455 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-26455 exists.

## Other vulnerabilities in n/a

- [CVE-2024-4323](https://insights.sbomify.com/CVE-2024-4323/): Fluent Bit Memory Corruption Vulnerability (critical 9.8)
- [CVE-2021-36088](https://insights.sbomify.com/CVE-2021-36088/): Use after free in n/a (critical 9.8)
- [CVE-2025-12977](https://insights.sbomify.com/CVE-2025-12977/): CVE-2025-12977 (critical 9.1)
- [CVE-2025-12970](https://insights.sbomify.com/CVE-2025-12970/): CVE-2025-12970 (high 8.8)
- [CVE-2021-46878](https://insights.sbomify.com/CVE-2021-46878/): Use after free in n/a (high 7.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-26455 and fix it if it is affected.

What it is: CVE-2024-26455 is a high-severity use after free vulnerability in n/a, published on 26 Feb 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-26455 exists.

Affected packages and fixed versions:
- fluent-bit (Bitnami): affected from 2.2.2; fixed in 2.2.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-26455/ (Markdown: https://insights.sbomify.com/CVE-2024-26455/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-26455
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-26455
- OSV: https://osv.dev/vulnerability/CVE-2024-26455

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-26455/
Summaries are generated and may contain mistakes; the official description above is the record.
