CVE-2024-2651 Inefficient Regular Expression Complexity in GitLab

Medium 6.5 Published Updated

An attacker can cause a denial of service in GitLab by submitting maliciously crafted markdown content that triggers inefficient regular expression processing.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2024-2651?

CVE-2024-2651 is a medium-severity denial of service vulnerability in Gitlab Gitlab, published on 9 May 2024. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

An issue has been discovered in GitLab CE/EE affecting all versions before 16.9.7, all versions starting from 16.10 before 16.10.5, all versions starting from 16.11 before 16.11.2. It was possible for an attacker to cause a denial of service using maliciously crafted markdown content.

Weakness: CWE-1333

Which versions are affected by CVE-2024-2651?

1 open source package ship an affected version, including gitlab. It affects 1 product.

PackageAffectedFixed in
gitlab BitnamiAll versions16.9.7, 16.10.5, 16.11.2

Products include Gitlab Gitlab.

How do I fix CVE-2024-2651?

Upgrade gitlab to a fixed version for your release line: 16.9.7, 16.10.5 or 16.11.2.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2024-2651 being exploited?

There is no known exploitation of CVE-2024-2651 in the wild and no public exploit code.

All Gitlab Gitlab vulnerabilities

Sources

Also known as BIT-gitlab-2024-2651, GHSA-v3j6-jv37-286j, UBUNTU-CVE-2024-2651.

Is CVE-2024-2651 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free