{"answers":{"affected":"6 open source packages ship an affected version, including amphp/http and amphp/http-client.","exploited":"There is no known exploitation of CVE-2024-2653 in the wild and no public exploit code.","fix":"Upgrade amphp/http to a fixed version for your release line: 1.7.3 or 2.1.1.","what":"CVE-2024-2653 is a high-severity denial of service vulnerability in amphp/http, published on 3 Apr 2024. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2024-2653 and fix it if it is affected.\n\nWhat it is: CVE-2024-2653 is a high-severity denial of service vulnerability in amphp/http, published on 3 Apr 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2024-2653 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- amphp/http (Packagist): affected all versions; fixed in 1.7.3\n- amphp/http (Packagist): affected all versions; fixed in 1.7.3\n- amphp/http (Packagist): affected from 2.0.0; fixed in 2.1.1\n- amphp/http (Packagist): affected from 2.0.0; fixed in 2.1.1\n- amphp/http-client (Packagist): affected from 4.0.0-rc10 up to 4.0.0; no fix listed\n- amphp/http-client (Packagist): affected from 4.0.0-rc10 up to 4.0.0; no fix listed\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-2653/ (Markdown: https://insights.sbomify.com/CVE-2024-2653/index.md)","id":"CVE-2024-2653","markdown":"https://insights.sbomify.com/CVE-2024-2653/index.md","name":"CVE-2024-2653","record":{"aliases":["GHSA-qjfw-cvjf-f4fm"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"PHP HTTP library","requires_auth":"none","summary":"An attacker can cause an out-of-memory crash in the amphp/http library by sending unbounded CONTINUATION frames, leading to denial of service.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"certcc","cpe":[],"cvss":{"score":8.2,"severity":"high","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:H","version":"3.1"},"cwes":[],"description":"amphp/http will collect CONTINUATION frames in an unbounded buffer and will not check a limit until it has received the set END_HEADERS flag, resulting in an OOM crash.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"CVE-2024-2653","id":"CVE-2024-2653","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"denial_of_service","year":"2024"},"n_packages":6,"n_references":3,"next":{"headline":"File Manager \u003c= 7.2.5 - Authenticated (Administrator+) Directory Traversal","id":"CVE-2024-2654"},"packages":[{"ecosystem":"Packagist","fixed":["1.7.3"],"introduced":["0"],"last_affected":[],"package":"amphp/http","purl":null,"source":"GHSA-qjfw-cvjf-f4fm"},{"ecosystem":"Packagist","fixed":["1.7.3"],"introduced":["0"],"last_affected":[],"package":"amphp/http","purl":"pkg:composer/amphp/http","source":"GHSA-qjfw-cvjf-f4fm"},{"ecosystem":"Packagist","fixed":["2.1.1"],"introduced":["2.0.0"],"last_affected":[],"package":"amphp/http","purl":null,"source":"GHSA-qjfw-cvjf-f4fm"},{"ecosystem":"Packagist","fixed":["2.1.1"],"introduced":["2.0.0"],"last_affected":[],"package":"amphp/http","purl":"pkg:composer/amphp/http","source":"GHSA-qjfw-cvjf-f4fm"},{"ecosystem":"Packagist","fixed":[],"introduced":["4.0.0-rc10"],"last_affected":["4.0.0"],"package":"amphp/http-client","purl":null,"source":"GHSA-qjfw-cvjf-f4fm"},{"ecosystem":"Packagist","fixed":[],"introduced":["4.0.0-rc10"],"last_affected":["4.0.0"],"package":"amphp/http-client","purl":"pkg:composer/amphp/http-client","source":"GHSA-qjfw-cvjf-f4fm"}],"prev":{"headline":"This CVE ID has been rejected or withdrawn by its CVE Numbering Authority.","id":"CVE-2024-2652"},"products":["amphp/http","amphp/http-client"],"published":"2024-04-03","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-11-04","vendors":["AMPHP"]},"summary":"An attacker can cause an out-of-memory crash in the amphp/http library by sending unbounded CONTINUATION frames, leading to denial of service.","url":"https://insights.sbomify.com/CVE-2024-2653/"}