# CVE-2024-2653: CVE-2024-2653

> An attacker can cause an out-of-memory crash in the amphp/http library by sending unbounded CONTINUATION frames, leading to denial of service.

- **Severity:** High 8.2 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 3 Apr 2024
- **Updated:** 4 Nov 2025
- **Also known as:** GHSA-qjfw-cvjf-f4fm

## What is CVE-2024-2653?

CVE-2024-2653 is a high-severity denial of service vulnerability in amphp/http, published on 3 Apr 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

amphp/http will collect CONTINUATION frames in an unbounded buffer and will not check a limit until it has received the set END_HEADERS flag, resulting in an OOM crash.

## Which versions are affected by CVE-2024-2653?

6 open source packages ship an affected version, including amphp/http and amphp/http-client.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `amphp/http` | Packagist | All versions | 1.7.3 |
| `amphp/http` | Packagist | All versions | 1.7.3 |
| `amphp/http` | Packagist | From 2.0.0 | 2.1.1 |
| `amphp/http` | Packagist | From 2.0.0 | 2.1.1 |
| `amphp/http-client` | Packagist | From 4.0.0-rc10 to 4.0.0 | None |
| `amphp/http-client` | Packagist | From 4.0.0-rc10 to 4.0.0 | None |

## How do I fix CVE-2024-2653?

Upgrade amphp/http to a fixed version for your release line: 1.7.3 or 2.1.1.

## Is CVE-2024-2653 being exploited?

There is no known exploitation of CVE-2024-2653 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-2653 and fix it if it is affected.

What it is: CVE-2024-2653 is a high-severity denial of service vulnerability in amphp/http, published on 3 Apr 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-2653 in the wild and no public exploit code.

Affected packages and fixed versions:
- amphp/http (Packagist): affected all versions; fixed in 1.7.3
- amphp/http (Packagist): affected all versions; fixed in 1.7.3
- amphp/http (Packagist): affected from 2.0.0; fixed in 2.1.1
- amphp/http (Packagist): affected from 2.0.0; fixed in 2.1.1
- amphp/http-client (Packagist): affected from 4.0.0-rc10 up to 4.0.0; no fix listed
- amphp/http-client (Packagist): affected from 4.0.0-rc10 up to 4.0.0; no fix listed

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-2653/ (Markdown: https://insights.sbomify.com/CVE-2024-2653/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-2653
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-2653
- OSV: https://osv.dev/vulnerability/CVE-2024-2653

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-2653/
Summaries are generated and may contain mistakes; the official description above is the record.
