CVE-2024-2660 Vault TLS Cert Auth Method Did Not Correctly Validate OCSP Responses
Attackers can bypass TLS certificate authentication by exploiting improper OCSP response validation in HashiCorp Vault.
- Exploited in the wild
- Not known
- Login needed
- An administrator
- Attackable
- Local or same network only
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2024-2660?
CVE-2024-2660 is a medium-severity vulnerability in Hashicorp Vault, published on 4 Apr 2024. It can only be exploited from the same machine or local network, with no action from the victim.
Official description
Vault and Vault Enterprise TLS certificates auth method did not correctly validate OCSP responses when one or more OCSP sources were configured. This vulnerability, CVE-2024-2660, affects Vault and Vault Enterprise 1.14.0 and above, and is fixed in Vault 1.16.0 and Vault Enterprise 1.16.1, 1.15.7, and 1.14.11.
Weakness: CWE-636
Which versions are affected by CVE-2024-2660?
4 open source packages ship an affected version, including github.com/hashicorp/vault and vault. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
github.com/hashicorp/vault Go | All versions | 1.16.0 |
github.com/hashicorp/vault Go | All versions | 1.16.0 |
github.com/hashicorp/vault Go | All versions | 1.16.0 |
vault Bitnami | From 1.14.0 | 1.16.0 |
Linux distribution packages (1)
sops openSUSE:Tumbleweed | All versions | 3.9.0-1.1 |
Products include Hashicorp Vault.
How do I fix CVE-2024-2660?
Upgrade github.com/hashicorp/vault to 1.16.0 or later.
Is CVE-2024-2660 being exploited?
There is no known exploitation of CVE-2024-2660 in the wild and no public exploit code.
Other vulnerabilities in Hashicorp Vault
Sources
Also known as BIT-vault-2024-2660, GHSA-j2rp-gmqv-frhv, GO-2024-2690, openSUSE-SU-2024:14104-1.