# CVE-2024-2660: Vault TLS Cert Auth Method Did Not Correctly Validate OCSP Responses

> Attackers can bypass TLS certificate authentication by exploiting improper OCSP response validation in HashiCorp Vault.

- **Severity:** Medium 6.4 (`CVSS:3.1/AV:A/AC:H/PR:H/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 4 Apr 2024
- **Updated:** 26 Sep 2024
- **Also known as:** BIT-vault-2024-2660, GHSA-j2rp-gmqv-frhv, GO-2024-2690, openSUSE-SU-2024:14104-1

## What is CVE-2024-2660?

CVE-2024-2660 is a medium-severity vulnerability in Hashicorp Vault, published on 4 Apr 2024. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

Vault and Vault Enterprise TLS certificates auth method did not correctly validate OCSP responses when one or more OCSP sources were configured. This vulnerability, CVE-2024-2660, affects Vault and Vault Enterprise 1.14.0 and above, and is fixed in Vault 1.16.0 and Vault Enterprise 1.16.1, 1.15.7, and 1.14.11.

Weakness: CWE-636 (Not Failing Securely)

## Which versions are affected by CVE-2024-2660?

4 open source packages ship an affected version, including github.com/hashicorp/vault and vault. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/hashicorp/vault` | Go | All versions | 1.16.0 |
| `github.com/hashicorp/vault` | Go | All versions | 1.16.0 |
| `github.com/hashicorp/vault` | Go | All versions | 1.16.0 |
| `vault` | Bitnami | From 1.14.0 | 1.16.0 |
| `sops` | openSUSE:Tumbleweed | All versions | 3.9.0-1.1 |

Products: Hashicorp Vault.

## How do I fix CVE-2024-2660?

Upgrade github.com/hashicorp/vault to 1.16.0 or later.

## Is CVE-2024-2660 being exploited?

There is no known exploitation of CVE-2024-2660 in the wild and no public exploit code.

## Other vulnerabilities in Hashicorp Vault

- [CVE-2020-35192](https://insights.sbomify.com/CVE-2020-35192/): Hardcoded credentials in n/a (critical 9.8)
- [CVE-2020-12757](https://insights.sbomify.com/CVE-2020-12757/): Improper Input Validation in HashiCorp Vault (critical 9.8)
- [CVE-2025-6000](https://insights.sbomify.com/CVE-2025-6000/): Arbitrary Remote Code Execution via Plugin Catalog Abuse (critical 9.1)
- [CVE-2022-40186](https://insights.sbomify.com/CVE-2022-40186/): HashiCorp Vault vulnerable to incorrect metadata access (critical 9.1)
- [CVE-2022-36129](https://insights.sbomify.com/CVE-2022-36129/): Missing authorization in n/a (critical 9.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-2660 and fix it if it is affected.

What it is: CVE-2024-2660 is a medium-severity vulnerability in Hashicorp Vault, published on 4 Apr 2024. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-2660 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/hashicorp/vault (Go): affected all versions; fixed in 1.16.0
- github.com/hashicorp/vault (Go): affected all versions; fixed in 1.16.0
- github.com/hashicorp/vault (Go): affected all versions; fixed in 1.16.0
- vault (Bitnami): affected from 1.14.0; fixed in 1.16.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-2660/ (Markdown: https://insights.sbomify.com/CVE-2024-2660/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-2660
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-2660
- OSV: https://osv.dev/vulnerability/CVE-2024-2660

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-2660/
Summaries are generated and may contain mistakes; the official description above is the record.
