# CVE-2024-27083: Flask-AppBuilder's OAuth login page subject to Cross Site Scripting (XSS)

> An attacker can execute malicious JavaScript in a user's browser via a crafted URL on the OAuth login page of Flask-AppBuilder.

- **Severity:** Medium 4.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 28 Feb 2024
- **Updated:** 8 Aug 2024
- **Also known as:** GHSA-fqxj-46wg-9v84, PYSEC-2026-1381

## What is CVE-2024-27083?

CVE-2024-27083 is a medium-severity cross-site scripting vulnerability in dpgaspar Flask-AppBuilder, published on 28 Feb 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Flask-AppBuilder is an application development framework, built on top of Flask. A Cross-Site Scripting (XSS) vulnerability has been discovered on the OAuth login page. An attacker could trick a user to follow a specially crafted URL to the OAuth login page. This URL could inject and execute malicious javascript code that would get executed on the user's browser. This issue was introduced on 4.1.4 and patched on 4.2.1.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2024-27083?

3 open source packages ship an affected version, including flask-appbuilder and Flask-AppBuilder. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `flask-appbuilder` | PyPI | From 4.1.4 | 4.2.1 |
| `flask-appbuilder` | PyPI | From 4.1.4 | 4.2.1 |
| `Flask-AppBuilder` | PyPI | From 4.1.4 | 4.2.1 |

Products: Dpgaspar Flask-Appbuilder.

## How do I fix CVE-2024-27083?

Upgrade flask-appbuilder to 4.2.1 or later.

## Is CVE-2024-27083 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-27083 exists.

## Other vulnerabilities in dpgaspar Flask-AppBuilder

- [CVE-2024-25128](https://insights.sbomify.com/CVE-2024-25128/): Flask-AppBuilder incorrect authentication when using auth type OpenID (critical 9.1)
- [CVE-2021-41265](https://insights.sbomify.com/CVE-2021-41265/): Improper Authentication in Flask-AppBuilder (high 8.1)
- [CVE-2023-29005](https://insights.sbomify.com/CVE-2023-29005/): No Rate Limiting on Login AUTH DB (high 7.5)
- [CVE-2021-32805](https://insights.sbomify.com/CVE-2021-32805/): URL Redirection to Untrusted Site ('Open Redirect') in Flask-AppBuilder (high 7.2)
- [CVE-2025-58065](https://insights.sbomify.com/CVE-2025-58065/): Flask App Builder has an Authentication Bypass vulnerability when using non AUTH_DB methods (medium 6.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-27083 and fix it if it is affected.

What it is: CVE-2024-27083 is a medium-severity cross-site scripting vulnerability in dpgaspar Flask-AppBuilder, published on 28 Feb 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-27083 exists.

Affected packages and fixed versions:
- flask-appbuilder (PyPI): affected from 4.1.4; fixed in 4.2.1
- flask-appbuilder (PyPI): affected from 4.1.4; fixed in 4.2.1
- Flask-AppBuilder (PyPI): affected from 4.1.4; fixed in 4.2.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-27083/ (Markdown: https://insights.sbomify.com/CVE-2024-27083/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-27083
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-27083
- OSV: https://osv.dev/vulnerability/CVE-2024-27083

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-27083/
Summaries are generated and may contain mistakes; the official description above is the record.
