# CVE-2024-27087: Kirby cross-site scripting (XSS) in the link field "Custom" type

> Attackers can execute arbitrary JavaScript via the Custom link type in Kirby CMS, potentially compromising user sessions or data.

- **Severity:** Medium 4.6 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 26 Feb 2024
- **Updated:** 2 Aug 2024
- **Also known as:** GHSA-63h4-w25c-3qv4

## What is CVE-2024-27087?

CVE-2024-27087 is a medium-severity cross-site scripting vulnerability in getkirby kirby, published on 26 Feb 2024. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

Kirby is a content management system. The new link field introduced in Kirby 4 allows several different link types that each validate the entered link to the relevant URL format. It also includes a "Custom" link type for advanced use cases that don't fit any of the pre-defined link formats.  As the "Custom" link type is meant to be flexible, it also allows the javascript: URL scheme. In some use cases this can be intended, but it can also be misused by attackers to execute arbitrary JavaScript code when a user or visitor clicks on a link that is generated from the contents of the link field. This vulnerability is patched in 4.1.1.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2024-27087?

2 open source packages ship an affected version, including getkirby/cms. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `getkirby/cms` | Packagist | From 4.0.0 | 4.1.1 |
| `getkirby/cms` | Packagist | From 4.0.0 | 4.1.1 |

Products: Getkirby Kirby.

## How do I fix CVE-2024-27087?

Upgrade getkirby/cms to 4.1.1 or later.

## Is CVE-2024-27087 being exploited?

There is no known exploitation of CVE-2024-27087 in the wild and no public exploit code.

## Other vulnerabilities in getkirby kirby

- [CVE-2024-26483](https://insights.sbomify.com/CVE-2024-26483/): Kirby vulnerable to unrestricted file upload of user avatar images (high 8.8)
- [CVE-2024-41964](https://insights.sbomify.com/CVE-2024-41964/): Insufficient permission checks in the language settings in Kirby CMS (high 8.1)
- [CVE-2026-34587](https://insights.sbomify.com/CVE-2026-34587/): Kirby has Server-Side Template Injection (SSTI) via double template resolution in option rendering (high 7.6)
- [CVE-2021-29460](https://insights.sbomify.com/CVE-2021-29460/): Cross-site scripting (XSS) from unsanitized uploaded SVG files (high 7.6)
- [CVE-2023-38489](https://insights.sbomify.com/CVE-2023-38489/): Kirby vulnerable to Insufficient Session Expiration after a password change (high 7.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-27087 and fix it if it is affected.

What it is: CVE-2024-27087 is a medium-severity cross-site scripting vulnerability in getkirby kirby, published on 26 Feb 2024. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2024-27087 in the wild and no public exploit code.

Affected packages and fixed versions:
- getkirby/cms (Packagist): affected from 4.0.0; fixed in 4.1.1
- getkirby/cms (Packagist): affected from 4.0.0; fixed in 4.1.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-27087/ (Markdown: https://insights.sbomify.com/CVE-2024-27087/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-27087
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-27087
- OSV: https://osv.dev/vulnerability/CVE-2024-27087

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-27087/
Summaries are generated and may contain mistakes; the official description above is the record.
