CVE-2024-27088 es5-ext Regular Expression Denial of Service in `function#copy` and `function#toStringTokens`

None 0.0 Published Updated

Attackers can cause application stalls by passing functions with long names to es5-ext, requiring an upgrade to the patched version.

Exploited in the wild
Not known
Login needed
An administrator
Attackable
Local or same network only
Victim action needed
Not needed
Fix
Available

What is CVE-2024-27088?

CVE-2024-27088 is a denial of service vulnerability in medikoo es5-ext, published on 26 Feb 2024. It can only be exploited from the same machine or local network, with no action from the victim.

Official description

es5-ext contains ECMAScript 5 extensions. Passing functions with very long names or complex default argument names into `function#copy` or `function#toStringTokens` may cause the script to stall. The vulnerability is patched in v0.10.63.

Weakness: CWE-400, CWE-1333

Which versions are affected by CVE-2024-27088?

2 open source packages ship an affected version, including es5-ext. It affects 1 product.

PackageAffectedFixed in
es5-ext npmFrom 0.10.00.10.63
es5-ext npmFrom 0.10.00.10.63

Products include Medikoo Es5-Ext.

How do I fix CVE-2024-27088?

Upgrade es5-ext to 0.10.63 or later.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2024-27088 being exploited?

There is no known exploitation of CVE-2024-27088 in the wild and no public exploit code.

Public exploit code: 1 proofs of concept on GitHub.

Sources

Also known as CLSA-2026-1773793041, CLSA-2026-1781139201, DEBIAN-CVE-2024-27088, GHSA-4gmj-3p3h-gm8h, MINI-4m88-hcrx-c9pf, MINI-7f4f-f768-4f3h and 2 more.

Is CVE-2024-27088 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free