{"answers":{"affected":"2 open source packages ship an affected version, including es5-ext. It affects 1 product.","exploited":"There is no known exploitation of CVE-2024-27088 in the wild and no public exploit code.","fix":"Upgrade es5-ext to 0.10.63 or later.","what":"CVE-2024-27088 is a denial of service vulnerability in medikoo es5-ext, published on 26 Feb 2024. It can only be exploited from the same machine or local network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2024-27088 and fix it if it is affected.\n\nWhat it is: CVE-2024-27088 is a denial of service vulnerability in medikoo es5-ext, published on 26 Feb 2024. It can only be exploited from the same machine or local network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2024-27088 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- es5-ext (npm): affected from 0.10.0; fixed in 0.10.63\n- es5-ext (npm): affected from 0.10.0; fixed in 0.10.63\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-27088/ (Markdown: https://insights.sbomify.com/CVE-2024-27088/index.md)","id":"CVE-2024-27088","markdown":"https://insights.sbomify.com/CVE-2024-27088/index.md","name":"CVE-2024-27088","record":{"aliases":["CLSA-2026-1773793041","CLSA-2026-1781139201","DEBIAN-CVE-2024-27088","GHSA-4gmj-3p3h-gm8h","MINI-4m88-hcrx-c9pf","MINI-7f4f-f768-4f3h","MINI-7wwm-cfmg-cc62","UBUNTU-CVE-2024-27088"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"JavaScript utility library","requires_auth":"high_privilege","summary":"Attackers can cause application stalls by passing functions with long names to es5-ext, requiring an upgrade to the patched version.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"es5-ext","vendor":"medikoo"}],"cvss":{"score":0,"severity":"low","source":"cna","vector":"CVSS:3.1/AV:L/AC:L/PR:H/UI:N/S:U/C:N/I:N/A:N","version":"3.1"},"cwes":[{"id":"CWE-400","name":"Uncontrolled Resource Consumption"},{"id":"CWE-1333","name":"Inefficient Regular Expression Complexity"}],"description":"es5-ext contains ECMAScript 5 extensions. Passing functions with very long names or complex default argument names into `function#copy` or `function#toStringTokens` may cause the script to stall. The vulnerability is patched in v0.10.63.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":"2024-08-21","github_poc":1,"max_poc_stars":0,"metasploit":0,"nuclei":0,"refs":[{"date":"2024-08-21T05:21:38Z","kind":"github_poc","ref":"https://github.com/200101WhoAmI/CVE-2024-27088","stars":0,"title":"redos"}],"tier":"poc_unverified"},"has_fix":true,"headline":"es5-ext Regular Expression Denial of Service in `function#copy` and `function#toStringTokens`","id":"CVE-2024-27088","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"denial_of_service","year":"2024"},"n_packages":2,"n_references":4,"next":{"headline":"This candidate was withdrawn by its CNA.","id":"CVE-2024-27089"},"packages":[{"ecosystem":"npm","fixed":["0.10.63"],"introduced":["0.10.0"],"last_affected":[],"package":"es5-ext","purl":null,"source":"GHSA-4gmj-3p3h-gm8h"},{"ecosystem":"npm","fixed":["0.10.63"],"introduced":["0.10.0"],"last_affected":[],"package":"es5-ext","purl":"pkg:npm/es5-ext","source":"GHSA-4gmj-3p3h-gm8h"}],"prev":{"headline":"Kirby cross-site scripting (XSS) in the link field \"Custom\" type","id":"CVE-2024-27087"},"products":["es5-ext"],"published":"2024-02-26","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"},{"class":"open","licence":"CC0","name":"PoC-in-GitHub"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2024-08-09","vendors":["medikoo"]},"summary":"Attackers can cause application stalls by passing functions with long names to es5-ext, requiring an upgrade to the patched version.","url":"https://insights.sbomify.com/CVE-2024-27088/"}