{"answers":{"affected":"2 open source packages ship an affected version, including decidim.","exploited":"There is no known exploitation of CVE-2024-27090 in the wild and no public exploit code.","fix":"Upgrade decidim to 0.27.6 or later.","what":"CVE-2024-27090 is a medium-severity vulnerability in decidim, published on 10 Jul 2024. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2024-27090 and fix it if it is affected.\n\nWhat it is: CVE-2024-27090 is a medium-severity vulnerability in decidim, published on 10 Jul 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2024-27090 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- decidim (RubyGems): affected all versions; fixed in 0.27.6\n- decidim (RubyGems): affected all versions; fixed in 0.27.6\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-27090/ (Markdown: https://insights.sbomify.com/CVE-2024-27090/index.md)","id":"CVE-2024-27090","markdown":"https://insights.sbomify.com/CVE-2024-27090/index.md","name":"CVE-2024-27090","record":{"aliases":["GHSA-qcj6-vxwx-4rqv"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"Decidim participatory democracy framework","requires_auth":"none","summary":"Attackers can access data from unpublished or private resources if they know the slug or URL, affecting Decidim users.","user_interaction":"not_required","vuln_class":"information_disclosure"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":5.3,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N","version":"3.1"},"cwes":[{"id":"CWE-200","name":"Exposure of Sensitive Information to an Unauthorized Actor"}],"description":"Decidim is a participatory democracy framework, written in Ruby on Rails, originally developed for the Barcelona City government online and offline participation website. If an attacker can infer the slug or URL of an unpublished or private resource, and this resource can be embbeded (such as a Participatory Process, an Assembly, a Proposal, a Result, etc), then some data of this resource could be accessed. This vulnerability is fixed in 0.27.6.","ecosystems":["RubyGems"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Decidim vulnerable to data disclosure through the embed feature","id":"CVE-2024-27090","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"RubyGems","product":null,"products":[],"type":"information_disclosure","year":"2024"},"n_packages":2,"n_references":4,"next":{"headline":"GeoNode stored XSS to full account takeover","id":"CVE-2024-27091"},"packages":[{"ecosystem":"RubyGems","fixed":["0.27.6"],"introduced":["0"],"last_affected":[],"package":"decidim","purl":null,"source":"GHSA-qcj6-vxwx-4rqv"},{"ecosystem":"RubyGems","fixed":["0.27.6"],"introduced":["0"],"last_affected":[],"package":"decidim","purl":"pkg:gem/decidim","source":"GHSA-qcj6-vxwx-4rqv"}],"prev":{"headline":"This candidate was withdrawn by its CNA.","id":"CVE-2024-27089"},"products":["decidim"],"published":"2024-07-10","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2024-08-02","vendors":["decidim"]},"summary":"Attackers can access data from unpublished or private resources if they know the slug or URL, affecting Decidim users.","url":"https://insights.sbomify.com/CVE-2024-27090/"}