{"answers":{"affected":"3 open source packages ship an affected version, including geonode. It affects 1 product.","exploited":"There is no known exploitation of CVE-2024-27091 in the wild and no public exploit code.","fix":"Upgrade geonode to 4.2.3 or later.","what":"CVE-2024-27091 is a medium-severity cross-site scripting vulnerability in geonode, published on 27 Mar 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2024-27091 and fix it if it is affected.\n\nWhat it is: CVE-2024-27091 is a medium-severity cross-site scripting vulnerability in geonode, published on 27 Mar 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2024-27091 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- geonode (PyPI): affected from 3.2.1; fixed in 4.2.3\n- geonode (PyPI): affected from 3.2.1; fixed in 4.2.3\n- geonode (PyPI): affected from 3.2.1; fixed in 4.2.3\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-27091/ (Markdown: https://insights.sbomify.com/CVE-2024-27091/index.md)","id":"CVE-2024-27091","markdown":"https://insights.sbomify.com/CVE-2024-27091/index.md","name":"CVE-2024-27091","record":{"aliases":["GHSA-rwcv-whm8-fmxm","PYSEC-2024-320"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["account_takeover","security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"GeoNode geospatial CMS","requires_auth":"none","summary":"Stored XSS in GeoNode allows attackers to steal CSRF tokens and change victim email addresses, leading to full account takeover.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"geonode","vendor":"geosolutionsgroup"}],"cvss":{"score":6.1,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"GeoNode is a geospatial content management system, a platform for the management and publication of geospatial data. An issue exists within GEONODE where the current rich text editor is vulnerable to Stored XSS. The applications cookies are set securely, but it is possible to retrieve a victims CSRF token and issue a request to change another user's email address to perform a full account takeover. Due to the script element not impacting the CORS policy, requests will succeed. This vulnerability is fixed in 4.2.3.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"GeoNode stored XSS to full account takeover","id":"CVE-2024-27091","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"xss","year":"2024"},"n_packages":3,"n_references":2,"next":{"headline":"Content spoofing - real Hoppscotch emails","id":"CVE-2024-27092"},"packages":[{"ecosystem":"PyPI","fixed":["4.2.3"],"introduced":["3.2.1"],"last_affected":[],"package":"geonode","purl":null,"source":"GHSA-rwcv-whm8-fmxm"},{"ecosystem":"PyPI","fixed":["4.2.3"],"introduced":["3.2.1"],"last_affected":[],"package":"geonode","purl":"pkg:pypi/geonode","source":"GHSA-rwcv-whm8-fmxm"},{"ecosystem":"PyPI","fixed":["4.2.3"],"introduced":["3.2.1"],"last_affected":[],"package":"geonode","purl":"pkg:pypi/geonode","source":"PYSEC-2024-320"}],"prev":{"headline":"Decidim vulnerable to data disclosure through the embed feature","id":"CVE-2024-27090"},"products":["geonode"],"published":"2024-03-27","related":[{"cvss_score":7.5,"headline":"GeoNode SSRF Bypass to return internal host data","id":"CVE-2023-42439","kev_date_added":null,"published":"2023-09-15"},{"cvss_score":7.5,"headline":"Geonode Server Side Request Forgery vulnerability","id":"CVE-2023-40017","kev_date_added":null,"published":"2023-08-24"},{"cvss_score":7.5,"headline":"Geoserver for GeoNode sensitive information leak","id":"CVE-2023-28442","kev_date_added":null,"published":"2023-03-23"},{"cvss_score":6.5,"headline":"XML External Entity (XXE) injection in GeoServer style upload functionality","id":"CVE-2023-26043","kev_date_added":null,"published":"2023-02-27"},{"cvss_score":5.3,"headline":"GeoNode \u003c 4.4.5, 5.0.2 SSRF via Document Upload","id":"CVE-2026-39921","kev_date_added":null,"published":"2026-04-10"},{"cvss_score":5.3,"headline":"GeoNode SSRF via Service Registration","id":"CVE-2026-39922","kev_date_added":null,"published":"2026-04-10"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2024-08-02","vendors":["GeoNode"]},"summary":"Stored XSS in GeoNode allows attackers to steal CSRF tokens and change victim email addresses, leading to full account takeover.","url":"https://insights.sbomify.com/CVE-2024-27091/"}