# CVE-2024-27091: GeoNode stored XSS to full account takeover

> Stored XSS in GeoNode allows attackers to steal CSRF tokens and change victim email addresses, leading to full account takeover.

- **Severity:** Medium 6.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 27 Mar 2024
- **Updated:** 2 Aug 2024
- **Also known as:** GHSA-rwcv-whm8-fmxm, PYSEC-2024-320

## What is CVE-2024-27091?

CVE-2024-27091 is a medium-severity cross-site scripting vulnerability in geonode, published on 27 Mar 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

GeoNode is a geospatial content management system, a platform for the management and publication of geospatial data. An issue exists within GEONODE where the current rich text editor is vulnerable to Stored XSS. The applications cookies are set securely, but it is possible to retrieve a victims CSRF token and issue a request to change another user's email address to perform a full account takeover. Due to the script element not impacting the CORS policy, requests will succeed. This vulnerability is fixed in 4.2.3.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2024-27091?

3 open source packages ship an affected version, including geonode. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `geonode` | PyPI | From 3.2.1 | 4.2.3 |
| `geonode` | PyPI | From 3.2.1 | 4.2.3 |
| `geonode` | PyPI | From 3.2.1 | 4.2.3 |

Products: Geosolutionsgroup Geonode.

## How do I fix CVE-2024-27091?

Upgrade geonode to 4.2.3 or later.

## Is CVE-2024-27091 being exploited?

There is no known exploitation of CVE-2024-27091 in the wild and no public exploit code.

## Other vulnerabilities in geonode

- [CVE-2023-42439](https://insights.sbomify.com/CVE-2023-42439/): GeoNode SSRF Bypass to return internal host data (high 7.5)
- [CVE-2023-40017](https://insights.sbomify.com/CVE-2023-40017/): Geonode Server Side Request Forgery vulnerability (high 7.5)
- [CVE-2023-28442](https://insights.sbomify.com/CVE-2023-28442/): Geoserver for GeoNode sensitive information leak (high 7.5)
- [CVE-2023-26043](https://insights.sbomify.com/CVE-2023-26043/): XML External Entity (XXE) injection in GeoServer style upload functionality (medium 6.5)
- [CVE-2026-39921](https://insights.sbomify.com/CVE-2026-39921/): GeoNode < 4.4.5, 5.0.2 SSRF via Document Upload (medium 5.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-27091 and fix it if it is affected.

What it is: CVE-2024-27091 is a medium-severity cross-site scripting vulnerability in geonode, published on 27 Mar 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2024-27091 in the wild and no public exploit code.

Affected packages and fixed versions:
- geonode (PyPI): affected from 3.2.1; fixed in 4.2.3
- geonode (PyPI): affected from 3.2.1; fixed in 4.2.3
- geonode (PyPI): affected from 3.2.1; fixed in 4.2.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-27091/ (Markdown: https://insights.sbomify.com/CVE-2024-27091/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-27091
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-27091
- OSV: https://osv.dev/vulnerability/CVE-2024-27091

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-27091/
Summaries are generated and may contain mistakes; the official description above is the record.
