# CVE-2024-27101: Integer overflow in chunking helper causes dispatching to miss elements or panic

> An integer overflow in SpiceDB causes permission checks to miss elements or panic, leading to denial of service or incorrect access control results.

- **Severity:** High 7.3 (`CVSS:3.1/AV:N/AC:H/PR:H/UI:R/S:C/C:N/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 1 Mar 2024
- **Updated:** 16 Apr 2025
- **Also known as:** GHSA-h3m7-rqc4-7h9p, GO-2024-2597

## What is CVE-2024-27101?

CVE-2024-27101 is a high-severity vulnerability in authzed spicedb, published on 1 Mar 2024. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.

### Official description

SpiceDB is an open source, Google Zanzibar-inspired database for creating and managing security-critical application permissions. Integer overflow in chunking helper causes dispatching to miss elements or panic.  Any SpiceDB cluster with any schema where a resource being checked has more than 65535 relationships for the same resource and subject type is affected by this problem.  The CheckPermission, BulkCheckPermission, and LookupSubjects API methods are affected. This vulnerability is fixed in 1.29.2.

Weakness: CWE-190 (Integer Overflow or Wraparound)

## Which versions are affected by CVE-2024-27101?

3 open source packages ship an affected version, including github.com/authzed/spicedb. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/authzed/spicedb` | Go | All versions | 1.29.2 |
| `github.com/authzed/spicedb` | Go | All versions | 1.29.2 |
| `github.com/authzed/spicedb` | Go | All versions | 1.29.2 |

Products: Authzed Spicedb.

## How do I fix CVE-2024-27101?

Upgrade github.com/authzed/spicedb to 1.29.2 or later.

## Is CVE-2024-27101 being exploited?

There is no known exploitation of CVE-2024-27101 in the wild and no public exploit code.

## Other vulnerabilities in authzed spicedb

- [CVE-2023-29193](https://insights.sbomify.com/CVE-2023-29193/): SpiceDB binding metrics port to untrusted networks and can leak command-line flags (high 8.7)
- [CVE-2022-21646](https://insights.sbomify.com/CVE-2022-21646/): Lookup operations do not take into account wildcards in SpiceDB (high 8.1)
- [CVE-2026-40091](https://insights.sbomify.com/CVE-2026-40091/): SpiceDB: SPICEDB_DATASTORE_CONN_URI is leaked on startup logs (medium 6.0)
- [CVE-2023-46255](https://insights.sbomify.com/CVE-2023-46255/): `SPICEDB_DATASTORE_CONN_URI` is leaked when URI cannot be parsed (medium 4.2)
- [CVE-2025-49011](https://insights.sbomify.com/CVE-2025-49011/): SpiceDB checks involving relations with caveats can result in no permission when permission is expected (low 3.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-27101 and fix it if it is affected.

What it is: CVE-2024-27101 is a high-severity vulnerability in authzed spicedb, published on 1 Mar 2024. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2024-27101 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/authzed/spicedb (Go): affected all versions; fixed in 1.29.2
- github.com/authzed/spicedb (Go): affected all versions; fixed in 1.29.2
- github.com/authzed/spicedb (Go): affected all versions; fixed in 1.29.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-27101/ (Markdown: https://insights.sbomify.com/CVE-2024-27101/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-27101
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-27101
- OSV: https://osv.dev/vulnerability/CVE-2024-27101

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-27101/
Summaries are generated and may contain mistakes; the official description above is the record.
