CVE-2024-27136 Apache JSPWiki: Cross-site scripting vulnerability on upload page

Medium 6.1 Published Updated

Attackers can execute JavaScript in victims' browsers via the upload page, potentially stealing sensitive information.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2024-27136?

CVE-2024-27136 is a medium-severity cross-site scripting vulnerability in Apache JSPWiki, published on 24 Jun 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

Official description

XSS in Upload page in Apache JSPWiki 2.12.1 and priors allows the attacker to execute javascript in the victim's browser and get some sensitive information about the victim. Apache JSPWiki users should upgrade to 2.12.2 or later.

Weakness: CWE-79

Which versions are affected by CVE-2024-27136?

2 open source packages ship an affected version, including org.apache.jspwiki:jspwiki-main. It affects 1 product.

PackageAffectedFixed in
org.apache.jspwiki:jspwiki-main MavenAll versions2.12.2
org.apache.jspwiki:jspwiki-main MavenAll versions2.12.2

Products include Apache Jspwiki.

How do I fix CVE-2024-27136?

Upgrade org.apache.jspwiki:jspwiki-main to 2.12.2 or later.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2024-27136 being exploited?

There is no known exploitation of CVE-2024-27136 in the wild and no public exploit code.

Sources

Also known as GHSA-36gf-vpj2-j42w.

Is CVE-2024-27136 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free