CVE-2024-27137 Apache Cassandra: unrestricted deserialization of JMX authentication credentials
Local attackers can intercept JMX credentials via RMI registry manipulation to gain unauthorized access to Apache Cassandra operations.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Local or same network only
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2024-27137?
CVE-2024-27137 is a medium-severity unsafe deserialization vulnerability in Apache Cassandra, published on 4 Feb 2025. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Official description
In Apache Cassandra it is possible for a local attacker without access to the Apache Cassandra process or configuration files to manipulate the RMI registry to perform a man-in-the-middle attack and capture user names and passwords used to access the JMX interface. The attacker can then use these credentials to access the JMX interface and perform unauthorized operations.
This is same vulnerability that CVE-2020-13946 was issued for, but the Java option was changed in JDK10.
This issue affects Apache Cassandra from 4.0.2 through 5.0.2 running Java 11.
Operators are recommended to upgrade to a release equal to or later than 4.0.15, 4.1.8, or 5.0.3 which fixes the issue.
Weakness: CWE-287
Which versions are affected by CVE-2024-27137?
7 open source packages ship an affected version, including org.apache.cassandra:cassandra-all and cassandra. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
org.apache.cassandra:cassandra-all Maven | From 4.0.2 | 4.0.15 |
org.apache.cassandra:cassandra-all Maven | From 4.0.2 | 4.0.15 |
org.apache.cassandra:cassandra-all Maven | From 4.1.0 | 4.1.8 |
org.apache.cassandra:cassandra-all Maven | From 4.1.0 | 4.1.8 |
org.apache.cassandra:cassandra-all Maven | From 5.0-beta1 | 5.0.3 |
org.apache.cassandra:cassandra-all Maven | From 5.0-beta1 | 5.0.3 |
1 more packages
cassandra Bitnami | From 4.0.2 | 4.0.15, 4.1.8, 5.0.3 |
Products include Apache Cassandra.
How do I fix CVE-2024-27137?
Upgrade org.apache.cassandra:cassandra-all to a fixed version for your release line: 4.0.15, 4.1.8 or 5.0.3.
Upgrade, and only deserialise data from trusted sources or with an allow-list of types. More about Unsafe deserialization.
Is CVE-2024-27137 being exploited?
There is no known exploitation of CVE-2024-27137 in the wild and no public exploit code.
Other vulnerabilities in Apache Cassandra
- CVE-2016-3427 Oracle Java SE and JRockit Unspecified
- CVE-2018-8016 Missing Authentication for Critical Function in Apache Cassandra
- CVE-2021-44521 Remote code execution for scripted UDFs
- CVE-2026-27314 Apache Cassandra: Privilege escalation via ADD IDENTITY authorization bypass
- CVE-2025-26467 Apache Cassandra: User with MODIFY permission on ALL KEYSPACES can escalate privileges to superuser via unsafe actions (4.0.16 only)
Sources
Also known as AZL-56430, AZL-56446, BIT-cassandra-2024-27137, CLEANSTART-2026-AS32820, CLEANSTART-2026-VY06816, GHSA-rgfx-7p65-3ff4 and 2 more.