# CVE-2024-27137: Apache Cassandra: unrestricted deserialization of JMX authentication credentials

> Local attackers can intercept JMX credentials via RMI registry manipulation to gain unauthorized access to Apache Cassandra operations.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 4 Feb 2025
- **Updated:** 15 Feb 2025
- **Also known as:** AZL-56430, AZL-56446, BIT-cassandra-2024-27137, CLEANSTART-2026-AS32820, CLEANSTART-2026-VY06816, GHSA-rgfx-7p65-3ff4, MINI-g4q2-pp6f-537j, MINI-r979-v5f8-4q5r

## What is CVE-2024-27137?

CVE-2024-27137 is a medium-severity unsafe deserialization vulnerability in Apache Cassandra, published on 4 Feb 2025. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

In Apache Cassandra it is possible for a local attacker without access
 to the Apache Cassandra process or configuration files to manipulate 
the RMI registry to perform a man-in-the-middle attack and capture user 
names and passwords used to access the JMX interface. The attacker can 
then use these credentials to access the JMX interface and perform 
unauthorized operations.

This is same vulnerability that CVE-2020-13946 was issued for, but the Java option was changed in JDK10.

This issue affects Apache Cassandra from 4.0.2 through 5.0.2 running Java 11.

Operators are recommended to upgrade to a release equal to or later than 4.0.15, 4.1.8, or 5.0.3 which fixes the issue.

Weakness: CWE-287 (Improper Authentication)

## Which versions are affected by CVE-2024-27137?

7 open source packages ship an affected version, including org.apache.cassandra:cassandra-all and cassandra. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.cassandra:cassandra-all` | Maven | From 4.0.2 | 4.0.15 |
| `org.apache.cassandra:cassandra-all` | Maven | From 4.0.2 | 4.0.15 |
| `org.apache.cassandra:cassandra-all` | Maven | From 4.1.0 | 4.1.8 |
| `org.apache.cassandra:cassandra-all` | Maven | From 4.1.0 | 4.1.8 |
| `org.apache.cassandra:cassandra-all` | Maven | From 5.0-beta1 | 5.0.3 |
| `org.apache.cassandra:cassandra-all` | Maven | From 5.0-beta1 | 5.0.3 |
| `cassandra` | Bitnami | From 4.0.2 | 4.0.15, 4.1.8, 5.0.3 |

Products: Apache Cassandra.

## How do I fix CVE-2024-27137?

Upgrade org.apache.cassandra:cassandra-all to a fixed version for your release line: 4.0.15, 4.1.8 or 5.0.3.

## Is CVE-2024-27137 being exploited?

There is no known exploitation of CVE-2024-27137 in the wild and no public exploit code.

## Other vulnerabilities in Apache Cassandra

- [CVE-2016-3427](https://insights.sbomify.com/CVE-2016-3427/): Oracle Java SE and JRockit Unspecified (critical 9.8, exploited in the wild)
- [CVE-2018-8016](https://insights.sbomify.com/CVE-2018-8016/): Missing Authentication for Critical Function in Apache Cassandra (critical 9.8)
- [CVE-2021-44521](https://insights.sbomify.com/CVE-2021-44521/): Remote code execution for scripted UDFs (critical 9.1)
- [CVE-2026-27314](https://insights.sbomify.com/CVE-2026-27314/): Apache Cassandra: Privilege escalation via ADD IDENTITY authorization bypass (high 8.8)
- [CVE-2025-26467](https://insights.sbomify.com/CVE-2025-26467/): Apache Cassandra: User with MODIFY permission on ALL KEYSPACES can escalate privileges to superuser via unsafe actions (4.0.16 only) (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-27137 and fix it if it is affected.

What it is: CVE-2024-27137 is a medium-severity unsafe deserialization vulnerability in Apache Cassandra, published on 4 Feb 2025. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2024-27137 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.cassandra:cassandra-all (Maven): affected from 4.0.2; fixed in 4.0.15
- org.apache.cassandra:cassandra-all (Maven): affected from 4.0.2; fixed in 4.0.15
- org.apache.cassandra:cassandra-all (Maven): affected from 4.1.0; fixed in 4.1.8
- org.apache.cassandra:cassandra-all (Maven): affected from 4.1.0; fixed in 4.1.8
- org.apache.cassandra:cassandra-all (Maven): affected from 5.0-beta1; fixed in 5.0.3
- org.apache.cassandra:cassandra-all (Maven): affected from 5.0-beta1; fixed in 5.0.3
- cassandra (Bitnami): affected from 4.0.2; fixed in 4.0.15, 4.1.8, 5.0.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-27137/ (Markdown: https://insights.sbomify.com/CVE-2024-27137/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-27137
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-27137
- OSV: https://osv.dev/vulnerability/CVE-2024-27137

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-27137/
Summaries are generated and may contain mistakes; the official description above is the record.
