CVE-2024-27181 Apache Linkis Basic management services: Privilege Escalation Attack vulnerability

High 8.8 Published Updated

A trusted user can escalate privileges to access sensitive token information in Apache Linkis basic management services.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2024-27181?

CVE-2024-27181 is a high-severity vulnerability in Apache Linkis Basic management services, published on 2 Aug 2024. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

In Apache Linkis <= 1.5.0,

Privilege Escalation in Basic management services where the attacking user is

a trusted account

allows access to Linkis's Token information. Users are advised to upgrade to version 1.6.0, which fixes this issue.

Weakness: CWE-269

Which versions are affected by CVE-2024-27181?

2 open source packages ship an affected version, including org.apache.linkis:linkis. It affects 1 product.

PackageAffectedFixed in
org.apache.linkis:linkis MavenAll versions1.6.0
org.apache.linkis:linkis MavenAll versions1.6.0

Products include Apache Linkis.

How do I fix CVE-2024-27181?

Upgrade org.apache.linkis:linkis to 1.6.0 or later.

Is CVE-2024-27181 being exploited?

There is no known exploitation of CVE-2024-27181 in the wild and no public exploit code.

Sources

Also known as GHSA-v352-rg37-5q5m.

Is CVE-2024-27181 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free